summaryrefslogtreecommitdiffstats
path: root/package/libs/toolchain/Makefile
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2022-03-31 17:13:37 +0100
committerPaul Spooren <mail@aparcar.org>2022-04-01 12:54:58 +0100
commit950bd40a275d1a834c95d8f9830e1bfed4737a82 (patch)
tree09cb98504b7789bf401e366400b46832c8a492d0 /package/libs/toolchain/Makefile
parent1fa8780056a8c7a2e26c8b4d5e6979232f117349 (diff)
downloadopenwrt-950bd40a275d1a834c95d8f9830e1bfed4737a82.tar.gz
openwrt-950bd40a275d1a834c95d8f9830e1bfed4737a82.tar.bz2
openwrt-950bd40a275d1a834c95d8f9830e1bfed4737a82.zip
toolchain: reproducible libstdcpp
A Python script containing an unreproducible path is copied by default. Remove it before generating the package. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'package/libs/toolchain/Makefile')
-rw-r--r--package/libs/toolchain/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/libs/toolchain/Makefile b/package/libs/toolchain/Makefile
index 682efd1970..f9f8ac956b 100644
--- a/package/libs/toolchain/Makefile
+++ b/package/libs/toolchain/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=toolchain
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_LICENSE:=GPL-3.0-with-GCC-exception
@@ -490,6 +490,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
define Package/libstdcpp/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(TOOLCHAIN_DIR)/lib/libstdc++.so.* $(1)/usr/lib/
+ rm -rf $(1)/usr/lib/*-gdb.py
endef
define Package/libasan/install