summaryrefslogtreecommitdiffstats
path: root/package/libs/toolchain/Makefile
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2024-03-17 18:43:10 +0100
committerPaul Spooren <mail@aparcar.org>2024-03-22 22:14:22 +0100
commite8725a932e16eaf6ec51add8c084d959cbe32ff2 (patch)
tree1e6e0a3731bf9c4860b6d13fa08bea226f999a6f /package/libs/toolchain/Makefile
parent36acf88fe0d974a7de5c3be5d3303048c54ce6fb (diff)
downloadopenwrt-e8725a932e16eaf6ec51add8c084d959cbe32ff2.tar.gz
openwrt-e8725a932e16eaf6ec51add8c084d959cbe32ff2.tar.bz2
openwrt-e8725a932e16eaf6ec51add8c084d959cbe32ff2.zip
treewide: use APK compatible version schema
Different from OPKG, APK uses a deterministic version schema which chips the version into chunks and compares them individually. This enforces a certain schema which was previously entirely flexible. - Releases are added at the very and end prefixed with an `r` like `1.2.3-r3`. - Hashes are prefixed with a `~` like `1.2.3~abc123`. - Dates become semantic versions, like `2024.04.01` - Extra tags are possible like `_git`, `_alpha` and more. For full details see the APK test list: https://gitlab.alpinelinux.org/alpine/apk-tools/-/blob/master/test/version.data Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'package/libs/toolchain/Makefile')
-rw-r--r--package/libs/toolchain/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/libs/toolchain/Makefile b/package/libs/toolchain/Makefile
index 4f71d31b28..285fbcfa98 100644
--- a/package/libs/toolchain/Makefile
+++ b/package/libs/toolchain/Makefile
@@ -27,7 +27,7 @@ define Package/gcc/Default
SECTION:=libs
CATEGORY:=Base system
URL:=http://gcc.gnu.org/
- VERSION:=$(LIBGCC_VERSION)-$(PKG_RELEASE)
+ VERSION:=$(LIBGCC_VERSION)-r$(PKG_RELEASE)
endef
define Package/libgcc
@@ -230,7 +230,7 @@ endef
define Package/libc/Default
SECTION:=libs
CATEGORY:=Base system
- VERSION:=$(LIBC_VERSION)-$(PKG_RELEASE)
+ VERSION:=$(LIBC_VERSION)-r$(PKG_RELEASE)
DEPENDS:=+libgcc
URL:=$(LIBC_URL)
endef