summaryrefslogtreecommitdiffstats
path: root/package/libs/uclibc++/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-10-07 15:59:52 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2019-10-12 23:43:08 +0200
commit6ab386c9bc23420816fbcefc84b62cf5438b2c66 (patch)
treefa009cdf75a4dc6a0165d5d950f2948a2db5604e /package/libs/uclibc++/Makefile
parentc5829788c955efc9c52f8a740987e362cacd95d8 (diff)
downloadopenwrt-6ab386c9bc23420816fbcefc84b62cf5438b2c66.tar.gz
openwrt-6ab386c9bc23420816fbcefc84b62cf5438b2c66.tar.bz2
openwrt-6ab386c9bc23420816fbcefc84b62cf5438b2c66.zip
uClibc++: Fix three bugs
The first allows usage of several functions in the std namespace, which broke compilation of gddrescue specifically with uClibc-ng and uClibc++. The second allows usage of long long with normal C++11, which is part of the standard. Before, std=gnu++11 needed to be passsed to work around it. As a result of the second patch, the pedantic patch can safely be removed. Both patches are upstream backports. Added -std=c++11 to CFLAGS to guarentee proper inclusion of long long. Added another patch that fixes a typo with the long long support. Sent to upstream. Fixed up license information according to SPDX. Small cleanups for consistency. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/libs/uclibc++/Makefile')
-rw-r--r--package/libs/uclibc++/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/package/libs/uclibc++/Makefile b/package/libs/uclibc++/Makefile
index 3adf70b360..7a0d9094ff 100644
--- a/package/libs/uclibc++/Makefile
+++ b/package/libs/uclibc++/Makefile
@@ -10,18 +10,17 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=uclibc++
PKG_VERSION:=0.2.5
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=uClibc++-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://cxx.uclibc.org/src/
PKG_HASH:=596fb9ed7295564ce4c70ae6076a18f92e72f70310d70c98520bbca85c77895a
-
PKG_BUILD_DIR:=$(BUILD_DIR)/uClibc++-$(PKG_VERSION)
-PKG_BUILD_PARALLEL:=1
-PKG_USE_MIPS16:=0
-PKG_LICENSE:=LGPL-2.1+
+PKG_LICENSE:=LGPL-2.1-or-later
PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+PKG_USE_MIPS16:=0
include $(INCLUDE_DIR)/package.mk
@@ -45,7 +44,7 @@ UCLIBC_TARGET_ARCH:=$(shell echo $(ARCH) | sed -e s'/-.*//' \
-e 's/mipsel.*/mips/' \
)
-TARGET_CFLAGS += $(FPIC) -nostdinc++
+TARGET_CFLAGS += $(FPIC) -nostdinc++ -std=c++11
TARGET_LDFLAGS += -Wl,--gc-sections
ifneq ($(CONFIG_CCACHE),)