summaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorLucian Cristian <lucian.cristian@gmail.com>2021-08-31 10:04:36 +0300
committerChristian Lamparter <chunkeey@gmail.com>2021-11-01 00:56:51 +0100
commit8550086c24e54b8d333045315e59947b9badf08e (patch)
treeeecf5de86b99a52413ed0d8bf3d50f4c2a55cf8b /package/libs
parent78be2741aa85abe39809ff3f3ce3e10942138831 (diff)
downloadopenwrt-8550086c24e54b8d333045315e59947b9badf08e.tar.gz
openwrt-8550086c24e54b8d333045315e59947b9badf08e.tar.bz2
openwrt-8550086c24e54b8d333045315e59947b9badf08e.zip
elfutils: enable host build
frr 8.0 needs host libelf dev add option for host build tested on x86, ramips, kirkwood Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com> [changed commit author's email] Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/elfutils/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/libs/elfutils/Makefile b/package/libs/elfutils/Makefile
index d595e4caf2..b0c9b8bd8c 100644
--- a/package/libs/elfutils/Makefile
+++ b/package/libs/elfutils/Makefile
@@ -26,6 +26,7 @@ PKG_BUILD_DEPENDS:=!USE_GLIBC:argp-standalone
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
+include $(INCLUDE_DIR)/host-build.mk
define Package/elfutils/Default
SECTION:=libs
@@ -60,6 +61,12 @@ else
CONFIGURE_ARGS += --disable-nls
endif
+HOST_CONFIGURE_ARGS += \
+ --disable-debuginfod \
+ --disable-libdebuginfod \
+ --without-lzma \
+ --without-zstd
+
CONFIGURE_ARGS += \
--program-prefix=eu- \
--disable-debuginfod \
@@ -97,6 +104,7 @@ define Package/libelf/install
endef
# these lines need to be ordered by dependency because of ABI versioning
+$(eval $(call HostBuild))
$(eval $(call BuildPackage,libelf))
$(eval $(call BuildPackage,libdw))
$(eval $(call BuildPackage,libasm))