summaryrefslogtreecommitdiffstats
path: root/package/network/utils/uqmi/Makefile
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-02-02 21:16:21 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-03-21 18:28:22 +0100
commitda3700988d9e34e380bae21ee23d5458a7e972b4 (patch)
tree20d82e514ac77f4f0de8deb7f1274a8f409646df /package/network/utils/uqmi/Makefile
parent5c545bdb365a78b8995ddfa441a6018f7ff3c011 (diff)
downloadopenwrt-da3700988d9e34e380bae21ee23d5458a7e972b4.tar.gz
openwrt-da3700988d9e34e380bae21ee23d5458a7e972b4.tar.bz2
openwrt-da3700988d9e34e380bae21ee23d5458a7e972b4.zip
treewide: add support for "gc-sections" in PKG_BUILD_FLAGS
This reduces open coding and allows to easily add a knob to enable it treewide, where chosen packages can still opt-out via "no-gc-sections". Note: libnl, mbedtls and opkg only used the CFLAGS part without the LDFLAGS counterpart. That doesn't help at all if the goal is to produce smaller binaries. I consider that an accident, and this fixes it. Note: there are also packages using only the LDFLAGS part. I didn't touch those, as gc might have been disabled via CFLAGS intentionally. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'package/network/utils/uqmi/Makefile')
-rw-r--r--package/network/utils/uqmi/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/package/network/utils/uqmi/Makefile b/package/network/utils/uqmi/Makefile
index 02265d400c..989e7c11b6 100644
--- a/package/network/utils/uqmi/Makefile
+++ b/package/network/utils/uqmi/Makefile
@@ -14,6 +14,7 @@ PKG_LICENSE:=GPL-2.0
PKG_LICENSE_FILES:=
PKG_FLAGS:=nonshared
+PKG_BUILD_FLAGS:=gc-sections
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
@@ -33,13 +34,9 @@ endef
TARGET_CFLAGS += \
-I$(STAGING_DIR)/usr/include \
- -ffunction-sections \
- -fdata-sections \
-Wno-error=dangling-pointer \
-Wno-error=maybe-uninitialized
-TARGET_LDFLAGS += -Wl,--gc-sections
-
CMAKE_OPTIONS += \
-DDEBUG=1