summaryrefslogtreecommitdiffstats
path: root/package/system/procd/Makefile
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-02-02 21:33:38 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-03-21 18:28:22 +0100
commit07730ff3465d3cede3026cdd1c17453930f055ce (patch)
tree71c8f06b42de3b1ff0d1c02c0068d718c3a08a62 /package/system/procd/Makefile
parentda3700988d9e34e380bae21ee23d5458a7e972b4 (diff)
downloadopenwrt-07730ff3465d3cede3026cdd1c17453930f055ce.tar.gz
openwrt-07730ff3465d3cede3026cdd1c17453930f055ce.tar.bz2
openwrt-07730ff3465d3cede3026cdd1c17453930f055ce.zip
treewide: add support for "lto" in PKG_BUILD_FLAGS
This reduces open coding and allows to easily add a knob to enable it treewide, where chosen packages can still opt-out via "no-lto". Some packages used LTO, but not the linker plugin. This unifies 'em all to attempt to produce better code. Quoting man gcc(1): "This improves the quality of optimization by exposing more code to the link-time optimizer." Also use -flto=auto instead of -flto=jobserver, as it's not guaranteed that every buildsystem uses +$(MAKE) correctly. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'package/system/procd/Makefile')
-rw-r--r--package/system/procd/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index 56aa9e0b35..2d51b51ad7 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -22,6 +22,7 @@ PKG_LICENSE_FILES:=
PKG_MAINTAINER:=John Crispin <john@phrozen.org>
+PKG_BUILD_FLAGS:=lto
PKG_ASLR_PIE_REGULAR:=1
PKG_CONFIG_DEPENDS:= \
CONFIG_TARGET_INIT_PATH CONFIG_KERNEL_SECCOMP CONFIG_PROCD_SHOW_BOOT \
@@ -36,9 +37,6 @@ endif
CMAKE_OPTIONS += -DEARLY_PATH="$(TARGET_INIT_PATH)"
-TARGET_CFLAGS += -flto
-TARGET_LDFLAGS += -flto
-
define Package/procd/Default
SECTION:=base
CATEGORY:=Base system