summaryrefslogtreecommitdiffstats
path: root/package/system/procd/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-12-20 02:21:23 +0000
committerDaniel Golle <daniel@makrotopia.org>2021-12-20 02:23:47 +0000
commit15d0c4d5cdd73b2a81f32478e0c2ec7d832ad191 (patch)
treee0240b0bb0f5c0a92a2a56a0d23d07c077726d26 /package/system/procd/Makefile
parent54cfe0774ce4203d23ffcb397ba15bd36968d098 (diff)
downloadopenwrt-15d0c4d5cdd73b2a81f32478e0c2ec7d832ad191.tar.gz
openwrt-15d0c4d5cdd73b2a81f32478e0c2ec7d832ad191.tar.bz2
openwrt-15d0c4d5cdd73b2a81f32478e0c2ec7d832ad191.zip
procd: update to git HEAD
eb522fc uxc: consider uvol and etc location for configurations 16a6ee9 uxc: integrate console into uxc 129d050 remove ujail-console Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/system/procd/Makefile')
-rw-r--r--package/system/procd/Makefile19
1 files changed, 3 insertions, 16 deletions
diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index 0f0df8c68d..1a4d2c7096 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -12,9 +12,9 @@ PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/procd.git
-PKG_MIRROR_HASH:=e2c60679cc39549e01c2c8e64eeb78278edb92953ce24e74b73da9ac0f21fe3d
-PKG_SOURCE_DATE:=2021-12-11
-PKG_SOURCE_VERSION:=bb95fe8df7115ab57792369c768927eafc042161
+PKG_MIRROR_HASH:=3ce6f5e2c12ae276af3ffe1755a495415f77184974206a44a3b083420aba52a8
+PKG_SOURCE_DATE:=2021-12-20
+PKG_SOURCE_VERSION:=129d050b9f5725ea4c54e1d906aba43eca95b860
CMAKE_INSTALL:=1
PKG_LICENSE:=GPL-2.0
@@ -72,13 +72,6 @@ define Package/procd-ujail
TITLE:=OpenWrt process jail helper
endef
-define Package/procd-ujail-console
- SECTION:=base
- CATEGORY:=Base system
- DEPENDS:=+procd-ujail +libubus +libubox
- TITLE:=OpenWrt process jail console
-endef
-
define Package/procd-seccomp
SECTION:=base
CATEGORY:=Base system
@@ -146,11 +139,6 @@ define Package/procd-ujail/install
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ujail $(1)/sbin/
endef
-define Package/procd-ujail-console/install
- $(INSTALL_DIR) $(1)/sbin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ujail-console $(1)/sbin/
-endef
-
define Package/procd-seccomp/install
$(INSTALL_DIR) $(1)/sbin $(1)/lib
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libpreload-seccomp.so $(1)/lib
@@ -173,6 +161,5 @@ endef
$(eval $(call BuildPackage,procd))
$(eval $(call BuildPackage,procd-selinux))
$(eval $(call BuildPackage,procd-ujail))
-$(eval $(call BuildPackage,procd-ujail-console))
$(eval $(call BuildPackage,procd-seccomp))
$(eval $(call BuildPackage,uxc))