summaryrefslogtreecommitdiffstats
path: root/package/system/procd/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-10-13 00:38:12 +0100
committerDaniel Golle <daniel@makrotopia.org>2021-10-13 00:40:29 +0100
commit213ce1d837f5eb98d76ae159e2f0b70f6e6c2537 (patch)
treee6bf2a420d3053a322bfbac1f34f1ce4186c3b59 /package/system/procd/Makefile
parentc1685d92e4452e4c9cc6ee5d7612b259396007a8 (diff)
downloadopenwrt-213ce1d837f5eb98d76ae159e2f0b70f6e6c2537.tar.gz
openwrt-213ce1d837f5eb98d76ae159e2f0b70f6e6c2537.tar.bz2
openwrt-213ce1d837f5eb98d76ae159e2f0b70f6e6c2537.zip
procd: update to git HEAD
97bcdcf uxc: fix segfault caused by use-after-free 6398e05 uxc: don't free the stack 324ebd0 jail: fs: add support for asymmetric mount bind c44ab7f jail: netifd: generate netifd uci config and mount it 82dd390 jail: make use of per-container netifd via ubus The new per-jail netifd is now configured by filtering the host network configuration. As libuci is used for that, procd-ujail now depends on libuci. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/system/procd/Makefile')
-rw-r--r--package/system/procd/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index 1e43c16330..6f506423f8 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -12,9 +12,9 @@ PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/procd.git
-PKG_SOURCE_DATE:=2021-09-15
-PKG_SOURCE_VERSION:=1eb4371e2534296d04580cb8b9cb5baa5f07e27d
-PKG_MIRROR_HASH:=d0e61032482eebb225ffbca8034b3d838eaa3db0dcd9b0166e106e729ce5320c
+PKG_SOURCE_DATE:=2021-10-13
+PKG_SOURCE_VERSION:=82dd39024f63e53becd07c89831ed7d5fac7f339
+PKG_MIRROR_HASH:=a9449894b4ce0b2860680c1691270d5fe9c84e4eecd48008ed732ef2d19af7db
CMAKE_INSTALL:=1
PKG_LICENSE:=GPL-2.0
@@ -68,7 +68,7 @@ define Package/procd-ujail
SECTION:=base
CATEGORY:=Base system
DEPENDS:=@KERNEL_NAMESPACES +@KERNEL_UTS_NS +@KERNEL_IPC_NS +@KERNEL_PID_NS \
- +libubox +libubus +libblobmsg-json
+ +libubox +libubus +libuci +libblobmsg-json
TITLE:=OpenWrt process jail helper
endef