summaryrefslogtreecommitdiffstats
path: root/package/system/procd/Makefile
diff options
context:
space:
mode:
authorRui Salvaterra <rsalvaterra@gmail.com>2020-07-13 14:03:47 +0100
committerRui Salvaterra <rsalvaterra@gmail.com>2022-03-03 20:22:25 +0000
commit247eaa44161b0a07e2dd40ffaa181d47ca10a96b (patch)
treee9e643867b617c6891ec95379ef90eea6c98277d /package/system/procd/Makefile
parent8235723c78b535635ef47951ec8fa61d6a4f3593 (diff)
downloadopenwrt-247eaa44161b0a07e2dd40ffaa181d47ca10a96b.tar.gz
openwrt-247eaa44161b0a07e2dd40ffaa181d47ca10a96b.tar.bz2
openwrt-247eaa44161b0a07e2dd40ffaa181d47ca10a96b.zip
procd: remove support for mounting /tmp in zram
The /tmp directory is mounted as tmpfs. The tmpfs filesystem is backed by anonymous memory, which means it can be swapped out at any time, if there is memory pressure [1]. For this reason, a zram swap device is a much better choice than mounting /tmp on zram, since it's able to compress all anonymous memory, and not just the memory assigned to /tmp. We already have the zram-swap package for this specific purpose, which means procd's tmp-on-zram is both redundant and more limited. A follow-up patch will remove support for mounting /tmp in zram from procd itself. [1] https://www.kernel.org/doc/Documentation/filesystems/tmpfs.txt Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
Diffstat (limited to 'package/system/procd/Makefile')
-rw-r--r--package/system/procd/Makefile11
1 files changed, 1 insertions, 10 deletions
diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index 8f814982bf..958a4808cb 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -24,8 +24,7 @@ PKG_MAINTAINER:=John Crispin <john@phrozen.org>
PKG_ASLR_PIE_REGULAR:=1
PKG_CONFIG_DEPENDS:= \
- CONFIG_TARGET_INIT_PATH CONFIG_KERNEL_SECCOMP \
- CONFIG_PROCD_SHOW_BOOT CONFIG_PROCD_ZRAM_TMPFS \
+ CONFIG_TARGET_INIT_PATH CONFIG_KERNEL_SECCOMP CONFIG_PROCD_SHOW_BOOT \
CONFIG_KERNEL_NAMESPACES CONFIG_PACKAGE_procd-ujail CONFIG_PACKAGE_procd-seccomp
include $(INCLUDE_DIR)/package.mk
@@ -96,10 +95,6 @@ config PROCD_SHOW_BOOT
default n
prompt "Print the shutdown to the console as well as logging it to syslog"
-config PROCD_ZRAM_TMPFS
- bool
- default n
- prompt "Mount /tmp using zram."
endmenu
endef
@@ -111,10 +106,6 @@ ifeq ($(CONFIG_PROCD_SHOW_BOOT),y)
CMAKE_OPTIONS += -DSHOW_BOOT_ON_CONSOLE=1
endif
-ifeq ($(CONFIG_PROCD_ZRAM_TMPFS),y)
- CMAKE_OPTIONS += -DZRAM_TMPFS=1
-endif
-
ifdef CONFIG_PACKAGE_procd-ujail
CMAKE_OPTIONS += -DJAIL_SUPPORT=1
endif