summaryrefslogtreecommitdiffstats
path: root/package/system/procd/Makefile
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2021-11-30 16:01:14 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2022-03-19 16:13:58 +0100
commitb9017384cae7bbc47186fdf35a80207844876a0d (patch)
treef845299df9f1931cf4d6acf19236e346176a582a /package/system/procd/Makefile
parentb04d38a2eaa5604aa7216e0c02846d96dc2d317f (diff)
downloadopenwrt-b9017384cae7bbc47186fdf35a80207844876a0d.tar.gz
openwrt-b9017384cae7bbc47186fdf35a80207844876a0d.tar.bz2
openwrt-b9017384cae7bbc47186fdf35a80207844876a0d.zip
procd: move service command to procd
The service command belongs to the procd and does not belong in the shinit. In the course of the move, the script was also checked with shellcheck and cleaned up. Signed-off-by: Florian Eckert <fe@dev.tdt.de>
Diffstat (limited to 'package/system/procd/Makefile')
-rw-r--r--package/system/procd/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index 958a4808cb..1d27920539 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -121,6 +121,7 @@ define Package/procd/install
$(INSTALL_BIN) ./files/reload_config $(1)/sbin/
$(INSTALL_CONF) ./files/hotplug*.json $(1)/etc/
$(INSTALL_DATA) ./files/procd.sh $(1)/lib/functions/
+ $(INSTALL_BIN) ./files/service $(1)/sbin/service
endef
Package/procd-selinux/install = $(Package/procd/install)