summaryrefslogtreecommitdiffstats
path: root/package/system/rpcd/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-10-29 12:14:16 +0100
committerDaniel Golle <daniel@makrotopia.org>2021-11-08 14:21:02 +0000
commit32ba52e2174d0c12fa476c3295daca12a864e547 (patch)
tree540a825ce85b5154a57eeec0954e45453cd1ec5c /package/system/rpcd/Makefile
parentafb9c24d906f300808964bad238cbd3dd94e739d (diff)
downloadopenwrt-32ba52e2174d0c12fa476c3295daca12a864e547.tar.gz
openwrt-32ba52e2174d0c12fa476c3295daca12a864e547.tar.bz2
openwrt-32ba52e2174d0c12fa476c3295daca12a864e547.zip
rpcd: reload rpcd on installation of rpcd-mod-*
When installing additional rpcd modules, a restart of rpcd is required. This often confuses users as even after installing rpcd-mod-rpcsys the relevant ubus objects are still missing until rpcd has been reloaded (or the system has been rebooted, obviously). Let rpcd-mod-* reload rpcd as post-install action. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/system/rpcd/Makefile')
-rw-r--r--package/system/rpcd/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/system/rpcd/Makefile b/package/system/rpcd/Makefile
index 2827e955db..9b1f239623 100644
--- a/package/system/rpcd/Makefile
+++ b/package/system/rpcd/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=rpcd
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/rpcd.git
@@ -84,6 +84,11 @@ define BuildPlugin
$(3)
endef
+ define Package/rpcd-mod-$(1)/postinst
+#!/bin/sh
+[ -n "$$$${IPKG_INSTROOT}" ] || /etc/init.d/rpcd reload
+ endef
+
define Package/rpcd-mod-$(1)/install
$(INSTALL_DIR) $$(1)/usr/lib/rpcd
$(INSTALL_BIN) $(PKG_BUILD_DIR)/$(1).so $$(1)/usr/lib/rpcd/