summaryrefslogtreecommitdiffstats
path: root/package/system/rpcd/Makefile
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2022-08-24 13:10:37 +0200
committerPetr Štetiar <ynezz@true.cz>2022-08-25 06:59:41 +0200
commit34ddd2e545f068e4684ecce98c1da3a6c7c9b04a (patch)
treeac4feafb667bc40ad0938b8999daf6fc384488cd /package/system/rpcd/Makefile
parentfe86b2ffaaf6059250e3ba0a9e1436312415e23f (diff)
downloadopenwrt-34ddd2e545f068e4684ecce98c1da3a6c7c9b04a.tar.gz
openwrt-34ddd2e545f068e4684ecce98c1da3a6c7c9b04a.tar.bz2
openwrt-34ddd2e545f068e4684ecce98c1da3a6c7c9b04a.zip
rpcd: bump version to 2022-08-24
gcc 10 with -O2 reports following: In function ‘strncpy’, inlined from ‘rpc_sys_packagelist’ at /opt/devel/openwrt/c-projects/rpcd/sys.c:244:4: /usr/include/x86_64-linux-gnu/bits/string_fortified.h:106:10: error: ‘__builtin_strncpy’ specified bound 128 equals destination size [-Werror=stringop-truncation] 106 | return __builtin___strncpy_chk (__dest, __src, __len, __bos (__dest)); | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ In function ‘strncpy’, inlined from ‘rpc_sys_packagelist’ at /opt/devel/openwrt/c-projects/rpcd/sys.c:227:4: /usr/include/x86_64-linux-gnu/bits/string_fortified.h:106:10: error: ‘__builtin_strncpy’ specified bound 128 equals destination size [-Werror=stringop-truncation] 106 | return __builtin___strncpy_chk (__dest, __src, __len, __bos (__dest)); | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ Since it is not possible to avoid truncation by strncpy, it is necessary to make sure the result of strncpy is properly NUL-terminated and the NUL must be inserted explicitly, after strncpy has returned. References: #10442 Reported-by: Alexey Smirnov <s.alexey@gmail.com> Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'package/system/rpcd/Makefile')
-rw-r--r--package/system/rpcd/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/system/rpcd/Makefile b/package/system/rpcd/Makefile
index a648629bb1..6571ca9c55 100644
--- a/package/system/rpcd/Makefile
+++ b/package/system/rpcd/Makefile
@@ -12,9 +12,9 @@ PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/rpcd.git
-PKG_MIRROR_HASH:=207013a5d51bc546fa7ae20f0c4763bd3ac3833513c10c00b2a0812c27dc2a36
-PKG_SOURCE_DATE:=2022-08-12
-PKG_SOURCE_VERSION:=ae5afea28375e28510f74fd404925ec9b2c4f430
+PKG_MIRROR_HASH:=52ca9beab4b18afec9717a5f05c5232ef6160c3ece82a020851ac3aeaa52a29a
+PKG_SOURCE_DATE:=2022-08-24
+PKG_SOURCE_VERSION:=82904bd4f92e5928d047db6396cc14ca2b07d89f
PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
PKG_LICENSE:=ISC