summaryrefslogtreecommitdiffstats
path: root/package/system/ubox/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-03-12 19:32:51 +0000
committerJohn Crispin <john@openwrt.org>2014-03-12 19:32:51 +0000
commit0dc9d8d6ffcdbdfda2723676f6ffc825a48a18b7 (patch)
tree0e723f844a2516729ec4ce71273b0e4480d73107 /package/system/ubox/Makefile
parent8411a5703f449a929623b7c41ba8b216685e8018 (diff)
downloadopenwrt-0dc9d8d6ffcdbdfda2723676f6ffc825a48a18b7.tar.gz
openwrt-0dc9d8d6ffcdbdfda2723676f6ffc825a48a18b7.tar.bz2
openwrt-0dc9d8d6ffcdbdfda2723676f6ffc825a48a18b7.zip
fstools: add the new fstools package
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 39895
Diffstat (limited to 'package/system/ubox/Makefile')
-rw-r--r--package/system/ubox/Makefile27
1 files changed, 2 insertions, 25 deletions
diff --git a/package/system/ubox/Makefile b/package/system/ubox/Makefile
index b3a4ba9eea..5bd7246858 100644
--- a/package/system/ubox/Makefile
+++ b/package/system/ubox/Makefile
@@ -28,22 +28,13 @@ define Package/ubox
TITLE:=OpenWrt system helper toolbox
endef
-define Package/block-mount
- SECTION:=base
- CATEGORY:=Base system
- TITLE:=Block device mounting and checking
- DEPENDS:=+ubox +libubox +libuci
-endef
-
define Package/ubox/install
$(INSTALL_DIR) $(1)/sbin $(1)/usr/sbin $(1)/lib/ $(1)/etc/init.d/
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{mount_root,kmodloader,logd,logread,validate_data} $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{kmodloader,logd,logread,validate_data} $(1)/sbin/
$(INSTALL_BIN) ./files/log.init $(1)/etc/init.d/log
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libvalidate.so $(1)/lib
- ln -s /sbin/mount_root $(1)/sbin/switch2jffs
- ln -s /sbin/mount_root $(1)/sbin/jffs2reset
- ln -s /sbin/mount_root $(1)/sbin/jffs2mark
+
ln -s /sbin/kmodloader $(1)/usr/sbin/rmmod
ln -s /sbin/kmodloader $(1)/usr/sbin/insmod
ln -s /sbin/kmodloader $(1)/usr/sbin/lsmod
@@ -51,18 +42,4 @@ define Package/ubox/install
ln -s /sbin/kmodloader $(1)/usr/sbin/modprobe
endef
-define Package/block-mount/install
- $(INSTALL_DIR) $(1)/sbin $(1)/usr/sbin $(1)/etc/hotplug.d/block $(1)/etc/init.d/ $(1)/etc/uci-defaults/
-
- $(INSTALL_BIN) ./files/fstab.init $(1)/etc/init.d/fstab
- $(INSTALL_DATA) ./files/fstab.default $(1)/etc/uci-defaults/10-fstab
- $(INSTALL_DATA) ./files/mount.hotplug $(1)/etc/hotplug.d/block/10-mount
-
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/block $(1)/sbin/
- ln -s /sbin/block $(1)/usr/sbin/swapon
- ln -s /sbin/block $(1)/usr/sbin/swapoff
-
-endef
-
$(eval $(call BuildPackage,ubox))
-$(eval $(call BuildPackage,block-mount))