summaryrefslogtreecommitdiffstats
path: root/package/system
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2023-05-17 21:08:40 +0800
committerPaul Spooren <mail@aparcar.org>2023-05-18 11:35:29 +0200
commit48ed07bc0b94b930d369baf911014bedd5bf6a7e (patch)
treea9b4a50b621a0212b349e73140e8066cf94476d5 /package/system
parent3a6657540c3d6fc50a63caf8432e301e825ada16 (diff)
downloadopenwrt-48ed07bc0b94b930d369baf911014bedd5bf6a7e.tar.gz
openwrt-48ed07bc0b94b930d369baf911014bedd5bf6a7e.tar.bz2
openwrt-48ed07bc0b94b930d369baf911014bedd5bf6a7e.zip
treewide: replace AUTORELEASE with real PKG_RELEASE
Based on Paul Fertser <fercerpav@gmail.com>'s guidance: Change AUTORELEASE in rules.mk to: ``` AUTORELEASE = $(if $(DUMP),0,$(shell sed -i "s/\$$(AUTORELEASE)/$(call commitcount,1)/" $(CURDIR)/Makefile)) ``` then update all affected packages by: ``` for i in $(git grep -l PKG_RELEASE:=.*AUTORELEASE | sed 's^.*/\([^/]*\)/Makefile^\1^';); do make package/$i/clean done ``` Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
Diffstat (limited to 'package/system')
-rw-r--r--package/system/opkg/Makefile2
-rw-r--r--package/system/ubox/Makefile2
-rw-r--r--package/system/zram-swap/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/package/system/opkg/Makefile b/package/system/opkg/Makefile
index 1841e190e6..3510e7435d 100644
--- a/package/system/opkg/Makefile
+++ b/package/system/opkg/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=opkg
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_RELEASE:=2
PKG_FLAGS:=essential
PKG_SOURCE_PROTO:=git
diff --git a/package/system/ubox/Makefile b/package/system/ubox/Makefile
index 1030c14bb1..e91763b074 100644
--- a/package/system/ubox/Makefile
+++ b/package/system/ubox/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ubox
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/ubox.git
diff --git a/package/system/zram-swap/Makefile b/package/system/zram-swap/Makefile
index d0d1baddd1..6e7e353f6f 100644
--- a/package/system/zram-swap/Makefile
+++ b/package/system/zram-swap/Makefile
@@ -5,7 +5,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=zram-swap
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_RELEASE:=32
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)