summaryrefslogtreecommitdiffstats
path: root/package/system
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2023-11-28 12:51:37 +0100
committerFelix Fietkau <nbd@nbd.name>2023-11-28 13:57:34 +0100
commit8e7ab041cebdd8fc8847963dabac618b20af1547 (patch)
treec8d3ee912140d072d87229d3428d0be63277c29a /package/system
parentf5a1e8953472a36868b793f87743db82195bf2b0 (diff)
downloadopenwrt-8e7ab041cebdd8fc8847963dabac618b20af1547.tar.gz
openwrt-8e7ab041cebdd8fc8847963dabac618b20af1547.tar.bz2
openwrt-8e7ab041cebdd8fc8847963dabac618b20af1547.zip
ubox: add acl file for logd
Fixes ubus reconnect, since the process user id changes to 'logd' Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/system')
-rw-r--r--package/system/ubox/Makefile3
-rw-r--r--package/system/ubox/files/logd.json4
2 files changed, 6 insertions, 1 deletions
diff --git a/package/system/ubox/Makefile b/package/system/ubox/Makefile
index e91763b074..17bade25e4 100644
--- a/package/system/ubox/Makefile
+++ b/package/system/ubox/Makefile
@@ -63,10 +63,11 @@ define Package/ubox/install
endef
define Package/logd/install
- $(INSTALL_DIR) $(1)/sbin $(1)/etc/init.d/
+ $(INSTALL_DIR) $(1)/sbin $(1)/etc/init.d/ $(1)/usr/share/acl.d
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{logd,logread} $(1)/sbin/
$(INSTALL_BIN) ./files/log.init $(1)/etc/init.d/log
+ $(INSTALL_DATA) ./files/logd.json $(1)/usr/share/acl.d
endef
$(eval $(call BuildPackage,ubox))
diff --git a/package/system/ubox/files/logd.json b/package/system/ubox/files/logd.json
new file mode 100644
index 0000000000..f0b2fb1e12
--- /dev/null
+++ b/package/system/ubox/files/logd.json
@@ -0,0 +1,4 @@
+{
+ "user": "logd",
+ "publish": [ "log" ]
+}