summaryrefslogtreecommitdiffstats
path: root/package/utils/busybox/Makefile
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-02-02 21:33:38 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-03-21 18:28:22 +0100
commit07730ff3465d3cede3026cdd1c17453930f055ce (patch)
tree71c8f06b42de3b1ff0d1c02c0068d718c3a08a62 /package/utils/busybox/Makefile
parentda3700988d9e34e380bae21ee23d5458a7e972b4 (diff)
downloadopenwrt-07730ff3465d3cede3026cdd1c17453930f055ce.tar.gz
openwrt-07730ff3465d3cede3026cdd1c17453930f055ce.tar.bz2
openwrt-07730ff3465d3cede3026cdd1c17453930f055ce.zip
treewide: add support for "lto" in PKG_BUILD_FLAGS
This reduces open coding and allows to easily add a knob to enable it treewide, where chosen packages can still opt-out via "no-lto". Some packages used LTO, but not the linker plugin. This unifies 'em all to attempt to produce better code. Quoting man gcc(1): "This improves the quality of optimization by exposing more code to the link-time optimizer." Also use -flto=auto instead of -flto=jobserver, as it's not guaranteed that every buildsystem uses +$(MAKE) correctly. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'package/utils/busybox/Makefile')
-rw-r--r--package/utils/busybox/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/package/utils/busybox/Makefile b/package/utils/busybox/Makefile
index 9573278945..d7ad8ca8fa 100644
--- a/package/utils/busybox/Makefile
+++ b/package/utils/busybox/Makefile
@@ -16,6 +16,7 @@ PKG_HASH:=542750c8af7cb2630e201780b4f99f3dcceeb06f505b479ec68241c1e6af61a5
PKG_BUILD_DEPENDS:=BUSYBOX_CONFIG_PAM:libpam
PKG_BUILD_PARALLEL:=1
+PKG_BUILD_FLAGS:=lto
PKG_CHECK_FORMAT_SECURITY:=0
PKG_LICENSE:=GPL-2.0
@@ -103,9 +104,6 @@ ifeq ($(BUILD_VARIANT),selinux)
LDLIBS += selinux sepol
endif
-TARGET_CFLAGS += -flto
-TARGET_LDFLAGS += -flto=jobserver -fuse-linker-plugin
-
MAKE_VARS :=
MAKE_FLAGS += \
EXTRA_CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \