summaryrefslogtreecommitdiffstats
path: root/package/utils/checkpolicy
diff options
context:
space:
mode:
authorDominick Grift <dominick.grift@defensec.nl>2021-10-22 13:51:14 +0200
committerDaniel Golle <daniel@makrotopia.org>2021-10-28 22:15:02 +0100
commitb97890d75e27c69afde9d3ba6f0f03d73b4f2e38 (patch)
tree22b09282bc996df680d432f546042a7f3e7b5272 /package/utils/checkpolicy
parentc8d1f8fda7722ab2e46847b49c2a1ef9afab6212 (diff)
downloadopenwrt-b97890d75e27c69afde9d3ba6f0f03d73b4f2e38.tar.gz
openwrt-b97890d75e27c69afde9d3ba6f0f03d73b4f2e38.tar.bz2
openwrt-b97890d75e27c69afde9d3ba6f0f03d73b4f2e38.zip
checkpolicy: update to version 3.3
Update VERSIONs to 3.3 for release. checkpolicy: Fix potential undefined shifts Update VERSIONs to 3.3-rc3 for release. checkpolicy: delay down-cast to avoid align warning checkpolicy: drop incorrect cast checkpolicy: update documentation checkpolicy: print reason of fopen failure checkpolicy: policy_define: cleanup declarations Update VERSIONs to 3.3-rc2 for release. checkpolicy: free extended permission memory checkpolicy: print warning on source line overflow checkpolicy: error out on parsing too big integers checkpolicy: avoid implicit conversion checkpolicy: resolve dismod memory leaks checkpolicy: add missing function declarations checkpolicy: mark file local functions in policy_define static checkpolicy: mark read-only parameters in module compiler const checkpolicy: misc checkpolicy tweaks checkpolicy: misc checkmodule tweaks checkpolicy: enclose macro argument in parentheses Update VERSIONs and Python bindings version to 3.3-rc1 for release checkpolicy: mark read-only parameters in policy define const checkpolicy/test: mark file local functions static checkpolicy: parse_util drop unused declaration checkpolicy: drop redundant cast to the same type checkpolicy: avoid potential use of uninitialized variable checkpolicy: check before potential NULL dereference checkpolicy: remove dead assignments checkpolicy: follow declaration-after-statement checkpolicy: use correct format specifier for unsigned checkpolicy: drop dead condition checkpolicy: simplify assignment checkpolicy: drop -pipe compile option checkpolicy: pass CFLAGS at link stage checkpolicy: silence -Wextra-semi-stmt warning checkpolicy: Do not automatically upgrade when using "-b" flag libsepol/checkpolicy: Set user roles using role value instead of dominance Signed-off-by: Dominick Grift <dominick.grift@defensec.nl>
Diffstat (limited to 'package/utils/checkpolicy')
-rw-r--r--package/utils/checkpolicy/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/utils/checkpolicy/Makefile b/package/utils/checkpolicy/Makefile
index 206bf201c0..e9c10e293f 100644
--- a/package/utils/checkpolicy/Makefile
+++ b/package/utils/checkpolicy/Makefile
@@ -6,12 +6,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=checkpolicy
-PKG_VERSION:=3.2
+PKG_VERSION:=3.3
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://github.com/SELinuxProject/selinux/releases/download/3.2
-PKG_HASH:=9b1c81fa86fe3867842164448d90c8e7ea94b2987497809c65d4caa87a5c5bc8
+PKG_SOURCE_URL:=https://github.com/SELinuxProject/selinux/releases/download/$(PKG_VERSION)
+PKG_HASH:=25c84edfa3a10ab8cb073b97bc55cb66377532d54a2723da9accdabd05431485
PKG_INSTALL:=1
PKG_BUILD_DEPENDS:=libselinux
HOST_BUILD_DEPENDS:=libselinux/host