summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorSergey Ponomarev <stokito@gmail.com>2023-12-03 18:11:38 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2024-05-06 13:41:43 +0200
commit1d4b88265b1befd36dc9e02881d57b46dfeb74b2 (patch)
tree59823c4e1cc15f68994f4b3f49544b30d6075353 /package
parent226b15f8859afa7bfdfb6aca2d48f2b4e83e74e2 (diff)
downloadopenwrt-1d4b88265b1befd36dc9e02881d57b46dfeb74b2.tar.gz
openwrt-1d4b88265b1befd36dc9e02881d57b46dfeb74b2.tar.bz2
openwrt-1d4b88265b1befd36dc9e02881d57b46dfeb74b2.zip
dropbear: use ssh-keygen as an alias for dropbearkey
The DropBear's dropbearkey supports limited set of arguments of OpenSSH ssh-keygen: -t, -q -N -Y After the change you can generate a key with the same command. Still many features of the original OpenSSH ssh-keygen are absent in the dropbearkey. If it's needed then users should install openssh-keygen package that will replace the /usr/bin/ssh-keygen with the full version. Signed-off-by: Sergey Ponomarev <stokito@gmail.com> Link: https://github.com/openwrt/openwrt/pull/14174 [ wrap commit description to 80 columns ] Link: https://github.com/openwrt/openwrt/pull/14174 Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/network/services/dropbear/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/network/services/dropbear/Makefile b/package/network/services/dropbear/Makefile
index b0f486f990..abb46157ea 100644
--- a/package/network/services/dropbear/Makefile
+++ b/package/network/services/dropbear/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dropbear
PKG_VERSION:=2022.83
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:= \
@@ -57,7 +57,7 @@ define Package/dropbear
CATEGORY:=Base system
TITLE:=Small SSH2 client/server
DEPENDS:= +DROPBEAR_ZLIB:zlib
- ALTERNATIVES:=
+ ALTERNATIVES:=100:/usr/bin/ssh-keygen:/usr/sbin/dropbear
$(if $(CONFIG_DROPBEAR_SCP),ALTERNATIVES+= \
100:/usr/bin/scp:/usr/sbin/dropbear,)
$(if $(CONFIG_DROPBEAR_DBCLIENT),ALTERNATIVES+= \