summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2023-12-21 17:29:45 +0100
committerFelix Fietkau <nbd@nbd.name>2024-01-09 11:06:24 +0100
commit32d2443476188f880395e52e0216c84dce9670f8 (patch)
treefcd28b30c0d476cabdddc827bffc11b39eb47881 /package
parent50416c18dd309fec75b6911221905cd0c0139b25 (diff)
downloadopenwrt-32d2443476188f880395e52e0216c84dce9670f8.tar.gz
openwrt-32d2443476188f880395e52e0216c84dce9670f8.tar.bz2
openwrt-32d2443476188f880395e52e0216c84dce9670f8.zip
libubox: work around recent macOS linker change
rpath handling seems to be more restrictive now. To deal with this, link the libubox library from STAGING_DIR_HOST to STAGING_DIR_HOSTPKG, so that packages installed to STAGING_DIR_HOSTPKG can pick it up. This mainly affects ucode, but possibly other host builds as well Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package')
-rw-r--r--package/libs/libubox/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/libs/libubox/Makefile b/package/libs/libubox/Makefile
index 549e604679..1ea886e6ac 100644
--- a/package/libs/libubox/Makefile
+++ b/package/libs/libubox/Makefile
@@ -105,6 +105,14 @@ CMAKE_HOST_OPTIONS += \
-DCMAKE_MACOSX_RPATH=1 \
-DCMAKE_INSTALL_RPATH="${STAGING_DIR_HOST}/lib" \
+ifeq ($(HOST_OS),Darwin)
+ define Host/Install
+ $(Host/Install/Default)
+ $(INSTALL_DIR) $(STAGING_DIR_HOSTPKG)/lib
+ cd "$(STAGING_DIR_HOSTPKG)/lib" && ln -sf ../../host/lib/libubox.* .
+ endef
+endif
+
$(eval $(call BuildPackage,libubox))
$(eval $(call BuildPackage,libblobmsg-json))
$(eval $(call BuildPackage,jshn))