summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorGeorgi Valkov <gvalkov@gmail.com>2024-05-27 23:23:20 +0300
committerRobert Marko <robimarko@gmail.com>2024-05-28 10:41:45 +0200
commit32e4c50d24d08570c6ae34d05922f1d9d879c0f2 (patch)
tree1a4c980272175a950a33298aabcc2888138f22f3 /package
parent9ec3b11d370b7ed209124165971f242c2d634ecc (diff)
downloadopenwrt-32e4c50d24d08570c6ae34d05922f1d9d879c0f2.tar.gz
openwrt-32e4c50d24d08570c6ae34d05922f1d9d879c0f2.tar.bz2
openwrt-32e4c50d24d08570c6ae34d05922f1d9d879c0f2.zip
ebtables: fix compilation with GCC14
Remove 100-musl_fix.patch, which is no longer needed and causes a build error with gcc-14. Fixes: useful_functions.c:63:41: error: passing argument 1 of 'ether_ntoa' from incompatible pointer type [-Wincompatible-pointer-types] 63 | printf("%s", ether_ntoa((struct ether_addr *) mac)); | ^~~~~~~~~~~~~~~~~~~~~~~~~ | | | struct ether_addr * In file included from include/ebtables_u.h:28, from useful_functions.c:25: /Volumes/wrt3200/openwrt/staging_dir/toolchain-arm_cortex-a9+vfpv3-d16_gcc-14.1.0_musl_eabi/include/netinet/ether.h:10:19: note: expected 'const struct ether_addr *' but argument is of type 'struct ether_addr *' 10 | char *ether_ntoa (const struct ether_addr *); | ^~~~~~~~~~~~~~~~~~~~~~~~~ Signed-off-by: Georgi Valkov <gvalkov@gmail.com> Link: https://github.com/openwrt/openwrt/pull/15576 Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/network/utils/ebtables/Makefile2
-rw-r--r--package/network/utils/ebtables/patches/100-musl_fix.patch10
2 files changed, 1 insertions, 11 deletions
diff --git a/package/network/utils/ebtables/Makefile b/package/network/utils/ebtables/Makefile
index 32a452b068..1eae868d7a 100644
--- a/package/network/utils/ebtables/Makefile
+++ b/package/network/utils/ebtables/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ebtables
PKG_SOURCE_DATE:=2018-06-27
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_URL:=https://git.netfilter.org/ebtables
PKG_SOURCE_PROTO:=git
diff --git a/package/network/utils/ebtables/patches/100-musl_fix.patch b/package/network/utils/ebtables/patches/100-musl_fix.patch
deleted file mode 100644
index f393ea7d91..0000000000
--- a/package/network/utils/ebtables/patches/100-musl_fix.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/include/ebtables_u.h
-+++ b/include/ebtables_u.h
-@@ -23,6 +23,7 @@
-
- #ifndef EBTABLES_U_H
- #define EBTABLES_U_H
-+#define _NETINET_IF_ETHER_H
- #include <netinet/in.h>
- #include <netinet/ether.h>
- #include <linux/netfilter_bridge/ebtables.h>