summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2021-12-30 20:05:15 +0100
committerChristian Lamparter <chunkeey@gmail.com>2022-01-08 23:20:21 +0100
commit3fabca88944e736176310be06e97f0f3cc9010cb (patch)
tree08ea5741e2ff20a5ef6d925873775645b0377a30 /package
parentd9ff9a4270de3f97124eac7ae9a5174c859f87cd (diff)
downloadopenwrt-3fabca88944e736176310be06e97f0f3cc9010cb.tar.gz
openwrt-3fabca88944e736176310be06e97f0f3cc9010cb.tar.bz2
openwrt-3fabca88944e736176310be06e97f0f3cc9010cb.zip
kernel: provide kmod-fixed-phy as separate kmod
Almost all targets have the fixed-phy feature built into the kernel. One big exception is x86. This caused a problem with the upcoming LAN78xx usb driver. Hence this patch breaks out the fixed-phy from of_mdio (which didn't include the .ko) and puts into a separate module. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/netdevices.mk19
1 files changed, 17 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index 91f51f5be6..6d263bdc34 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -1034,13 +1034,28 @@ endef
$(eval $(call KernelPackage,forcedeth))
+define KernelPackage/fixed-phy
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=MDIO Bus/PHY emulation with fixed speed/link PHYs
+ DEPENDS:=+kmod-libphy
+ KCONFIG:=CONFIG_FIXED_PHY
+ FILES:=$(LINUX_DIR)/drivers/net/phy/fixed_phy.ko
+ AUTOLOAD:=$(call AutoProbe,fixed_phy)
+endef
+
+define KernelPackage/fixed-phy/description
+ Kernel driver for "fixed" MDIO Bus to cover the boards
+ and devices that use PHYs that are not connected to the real MDIO bus.
+endef
+
+$(eval $(call KernelPackage,fixed-phy))
+
define KernelPackage/of-mdio
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=OpenFirmware MDIO support
- DEPENDS:=+kmod-libphy @!TARGET_x86
+ DEPENDS:=+kmod-libphy +kmod-fixed-phy @!TARGET_x86
KCONFIG:=CONFIG_OF_MDIO
FILES:= \
- $(LINUX_DIR)/drivers/net/phy/fixed_phy.ko \
$(LINUX_DIR)/drivers/of/of_mdio.ko@lt5.10 \
$(LINUX_DIR)/drivers/net/mdio/of_mdio.ko@ge5.10
AUTOLOAD:=$(call AutoLoad,41,of_mdio)