summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2019-09-20 11:40:52 +0200
committerJo-Philipp Wich <jo@mein.io>2019-09-20 13:27:21 +0200
commit4209b28d23b8bf28575af5e8904194f49b81532e (patch)
tree2f544ff20bb2945b19882c8a13a1600557fffcb8 /package
parentc79cb9fda71a49590dc785d7c6e1472eee134e02 (diff)
downloadopenwrt-4209b28d23b8bf28575af5e8904194f49b81532e.tar.gz
openwrt-4209b28d23b8bf28575af5e8904194f49b81532e.tar.bz2
openwrt-4209b28d23b8bf28575af5e8904194f49b81532e.zip
hostapd: fix OWE settings in client mode
This changes fixes the generation of the wpa_supplicant client configuration in WPA3 OWE client mode. Instead of incorrectly emitting key_mgmt=NONE, use the proper key_mgmt=OWE setting instead. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package')
-rw-r--r--package/network/services/hostapd/Makefile2
-rw-r--r--package/network/services/hostapd/files/hostapd.sh1
2 files changed, 2 insertions, 1 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 233ef389ae..e94d66211d 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd
-PKG_RELEASE:=9
+PKG_RELEASE:=10
PKG_SOURCE_URL:=http://w1.fi/hostap.git
PKG_SOURCE_PROTO:=git
diff --git a/package/network/services/hostapd/files/hostapd.sh b/package/network/services/hostapd/files/hostapd.sh
index 46acbefeee..c7f3ea2c1e 100644
--- a/package/network/services/hostapd/files/hostapd.sh
+++ b/package/network/services/hostapd/files/hostapd.sh
@@ -788,6 +788,7 @@ wpa_supplicant_add_network() {
none) ;;
owe)
hostapd_append_wpa_key_mgmt
+ key_mgmt="$wpa_key_mgmt"
;;
wep)
local wep_keyidx=0