summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorTony Ambardar <itugrok@yahoo.com>2024-04-03 15:31:29 -0700
committerRobert Marko <robimarko@gmail.com>2024-04-13 11:20:41 +0200
commit5b07c37dfa4625ad0256bf7a4f8386abe72a694b (patch)
tree66b5c9ea77f9b0ef5e15fb4fcef518995ed504c7 /package
parent2496f436a837f4d56a13883497ab5d07fb01d0f7 (diff)
downloadopenwrt-5b07c37dfa4625ad0256bf7a4f8386abe72a694b.tar.gz
openwrt-5b07c37dfa4625ad0256bf7a4f8386abe72a694b.tar.bz2
openwrt-5b07c37dfa4625ad0256bf7a4f8386abe72a694b.zip
libbpf: Update to v1.4.0
Update to the latest upstream release to include recent improvements and bugfixes, and update copyright. Remove MAKE_VARS usage in Makefile and drop 001-cflags.patch which are no longer needed. Also add flags to disable LTO, mistakenly dropped earlier. Link: https://github.com/libbpf/libbpf/releases/tag/v1.4.0 Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
Diffstat (limited to 'package')
-rw-r--r--package/libs/libbpf/Makefile14
-rw-r--r--package/libs/libbpf/patches/001-cflags.patch10
2 files changed, 5 insertions, 19 deletions
diff --git a/package/libs/libbpf/Makefile b/package/libs/libbpf/Makefile
index 913c025e54..666786e9f6 100644
--- a/package/libs/libbpf/Makefile
+++ b/package/libs/libbpf/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2020-2023 Tony Ambardar <itugrok@yahoo.com>
+# Copyright (C) 2020-2024 Tony Ambardar <itugrok@yahoo.com>
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,19 +8,19 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libbpf
-PKG_VERSION:=1.3.0
+PKG_VERSION:=1.4.0
PKG_RELEASE:=1
PKG_SOURCE_URL:=https://github.com/libbpf/libbpf
-PKG_MIRROR_HASH:=669d8db696f86f640f86edc358bffa2af8dda656b8e787b095de3578bd8d94ff
+PKG_MIRROR_HASH:=4c37636699c604de345937bdbdf8f2e6ce69cbf768a4aa669c32b542e5302de6
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=v1.3.0
+PKG_SOURCE_VERSION:=v1.4.0
PKG_ABI_VERSION:=$(firstword $(subst .,$(space),$(PKG_VERSION)))
PKG_MAINTAINER:=Tony Ambardar <itugrok@yahoo.com>
PKG_CPE_ID:=cpe:/a:libbpf_project:libbpf
-PKG_BUILD_FLAGS:=no-mips16
+PKG_BUILD_FLAGS:=no-mips16 no-gc-sections no-lto
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
@@ -41,10 +41,6 @@ define Package/libbpf/description
libbpf is a library for loading eBPF programs and reading and manipulating eBPF objects from user-space.
endef
-MAKE_VARS = \
- EXTRA_CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
- LDFLAGS="$(TARGET_LDFLAGS)"
-
MAKE_FLAGS += \
$(if $(findstring c,$(OPENWRT_VERBOSE)),V=1,V='') \
LIBSUBDIR=lib
diff --git a/package/libs/libbpf/patches/001-cflags.patch b/package/libs/libbpf/patches/001-cflags.patch
deleted file mode 100644
index 4c0e93a75b..0000000000
--- a/package/libs/libbpf/patches/001-cflags.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -34,6 +34,7 @@ ALL_CFLAGS := $(INCLUDES)
-
- SHARED_CFLAGS += -fPIC -fvisibility=hidden -DSHARED
-
-+CFLAGS = $(EXTRA_CFLAGS)
- CFLAGS ?= -g -O2 -Werror -Wall -std=gnu89
- ALL_CFLAGS += $(CFLAGS) \
- -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 \