summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorYanase Yuki <dev@zpc.st>2024-03-07 17:31:34 +0900
committerRobert Marko <robimarko@gmail.com>2024-04-05 15:08:38 +0200
commit63dd14b906e9eb27bc878b95ac6777a3624b1135 (patch)
tree557e10d0df29a2db8e8ce3d5fbbab698cd987467 /package
parent27a2b54cba1539fc0f3afdc3160722322fffdeb3 (diff)
downloadopenwrt-63dd14b906e9eb27bc878b95ac6777a3624b1135.tar.gz
openwrt-63dd14b906e9eb27bc878b95ac6777a3624b1135.tar.bz2
openwrt-63dd14b906e9eb27bc878b95ac6777a3624b1135.zip
gettext-full: link libiconv when building host pkg
On Fedora 40 system, some compile error happens when building iconv-ostream.c. Linking to libiconv-full fixes this. Signed-off-by: Yanase Yuki <dev@zpc.st>
Diffstat (limited to 'package')
-rw-r--r--package/libs/gettext-full/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/package/libs/gettext-full/Makefile b/package/libs/gettext-full/Makefile
index eb5b6d31bd..94b973d5c1 100644
--- a/package/libs/gettext-full/Makefile
+++ b/package/libs/gettext-full/Makefile
@@ -27,7 +27,7 @@ PKG_BUILD_PARALLEL:=0
PKG_FIXUP:=autoreconf
-HOST_BUILD_DEPENDS:=gperf/host libunistring/host libxml2/host
+HOST_BUILD_DEPENDS:=gperf/host libiconv-full/host libunistring/host libxml2/host
HOST_BUILD_PARALLEL:=0
PKG_SUBDIRS:= \
@@ -101,14 +101,12 @@ HOST_CONFIGURE_ARGS += \
--disable-java \
--disable-openmp \
--without-emacs \
+ --with-libiconv-prefix=$(STAGING_DIR_HOSTPKG) \
--with-libunistring-prefix=$(STAGING_DIR_HOSTPKG) \
--with-libxml2-prefix=$(STAGING_DIR_HOSTPKG)
HOST_CONFIGURE_VARS += \
EMACS="no" \
- am_cv_lib_iconv=no \
- am_cv_func_iconv=no \
- ac_cv_header_iconv_h=no \
HOST_CFLAGS += $(HOST_FPIC)