summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorAlberto Bursi <alberto.bursi@outlook.it>2019-09-16 00:54:20 +0200
committerPetr Štetiar <ynezz@true.cz>2019-09-19 23:43:27 +0200
commit827f47749b75dcc6b650297b9303c27127b15201 (patch)
treefc64e992a243b3b295b5d0315d8be79a51272ac2 /package
parentf974f8213b94578581b35e6b3f8fb1fd5a35f753 (diff)
downloadopenwrt-827f47749b75dcc6b650297b9303c27127b15201.tar.gz
openwrt-827f47749b75dcc6b650297b9303c27127b15201.tar.bz2
openwrt-827f47749b75dcc6b650297b9303c27127b15201.zip
kernel: add module for Emulex OneConnect 10Gbit
add module to support Emulex OneConnect common in 10Gbit SFP+ cards by Dell/HP/IBM supports OneConnect OCe10xxx OCe11xxx OCe14xxx, LightPulse LPe12xxx Signed-off-by: Alberto Bursi <alberto.bursi@outlook.it>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/netdevices.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index 4ed5736bb2..5f8d767679 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -1021,3 +1021,24 @@ define KernelPackage/bnx2x/description
endef
$(eval $(call KernelPackage,bnx2x))
+
+define KernelPackage/be2net
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=Broadcom Emulex OneConnect 10Gbps NIC
+ DEPENDS:=@PCI_SUPPORT +kmod-hwmon-core
+ FILES:=$(LINUX_DIR)/drivers/net/ethernet/emulex/benet/be2net.ko
+ KCONFIG:= \
+ CONFIG_BE2NET \
+ CONFIG_BE2NET_BE2=y \
+ CONFIG_BE2NET_BE3=y \
+ CONFIG_BE2NET_LANCER=y \
+ CONFIG_BE2NET_SKYHAWK=y \
+ CONFIG_BE2NET_HWMON=y
+ AUTOLOAD:=$(call AutoProbe,be2net)
+endef
+
+define KernelPackage/be2net/description
+ Broadcom Emulex OneConnect 10Gbit SFP+ support, OneConnect OCe10xxx OCe11xxx OCe14xxx, LightPulse LPe12xxx
+endef
+
+$(eval $(call KernelPackage,be2net))