summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorRoman Spychała <roed@onet.eu>2017-04-25 13:07:37 +0200
committerJohn Crispin <john@phrozen.org>2017-05-25 09:22:42 +0200
commit855f2ae4da365ac5033e6e0e71556be81633ca81 (patch)
treebb5e0081daa231350a74ae2fafe1e0f36bc535e1 /package
parente457d22261b2dbf5f75f5c73e6930bcecb8e8772 (diff)
downloadopenwrt-855f2ae4da365ac5033e6e0e71556be81633ca81.tar.gz
openwrt-855f2ae4da365ac5033e6e0e71556be81633ca81.tar.bz2
openwrt-855f2ae4da365ac5033e6e0e71556be81633ca81.zip
kernel: add kmod-usb-net-pl package
Kernel support for Prolific PL-2301/2302/25A1 based cables Signed-off-by: Roman Spychała <roed@onet.eu>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/usb.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index b0375dcb61..ee5b954381 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1322,6 +1322,19 @@ endef
$(eval $(call KernelPackage,usb-net-kalmia))
+define KernelPackage/usb-net-pl
+ TITLE:=Prolific PL-2301/2302/25A1 based cables
+ KCONFIG:=CONFIG_USB_NET_PLUSB
+ FILES:=$(LINUX_DIR)/drivers/net/usb/plusb.ko
+ AUTOLOAD:=$(call AutoProbe,plusb)
+ $(call AddDepends/usb-net)
+endef
+
+define KernelPackage/usb-net-pl/description
+ Kernel support for Prolific PL-2301/2302/25A1 based cables
+endef
+
+$(eval $(call KernelPackage,usb-net-pl))
define KernelPackage/usb-hid
TITLE:=Support for USB Human Input Devices