summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorWeijie Gao <hackpascal@gmail.com>2024-01-07 03:37:34 +0800
committerChuanhong Guo <gch981213@gmail.com>2024-05-04 14:14:24 +0800
commitb98355ed0fc488876c24c2649f289a3934dc8854 (patch)
treee81c1c8468a3e4561ffc18f79faf1c7ec54ed02f /package
parent159a2857360a0755c5bcf14d2d4d65bf04022936 (diff)
downloadopenwrt-b98355ed0fc488876c24c2649f289a3934dc8854.tar.gz
openwrt-b98355ed0fc488876c24c2649f289a3934dc8854.tar.bz2
openwrt-b98355ed0fc488876c24c2649f289a3934dc8854.zip
grub2: add EFI support for loongarch64
Add a new package for loongarch64 which only supports EFI. Signed-off-by: Weijie Gao <hackpascal@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/boot/grub2/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/boot/grub2/Makefile b/package/boot/grub2/Makefile
index 279f2bd3c6..14933e80ce 100644
--- a/package/boot/grub2/Makefile
+++ b/package/boot/grub2/Makefile
@@ -42,6 +42,7 @@ endef
Package/grub2=$(call Package/grub2/Default,x86,pc)
Package/grub2-efi=$(call Package/grub2/Default,x86,efi)
Package/grub2-efi-arm=$(call Package/grub2/Default,armsr,efi)
+Package/grub2-efi-loongarch64=$(call Package/grub2/Default,loongarch64,efi)
define Package/grub2-editenv
CATEGORY:=Utilities
@@ -191,6 +192,19 @@ define Package/grub2-efi-arm/install
reboot serial test efi_gop
endef
+define Package/grub2-efi-loongarch64/install
+ $(INSTALL_DIR) $(STAGING_DIR_IMAGE)/grub2
+ cp ./files/grub-early-gpt.cfg $(PKG_BUILD_DIR)/grub-early.cfg
+ $(STAGING_DIR_HOST)/bin/grub-mkimage \
+ -d $(PKG_BUILD_DIR)/grub-core \
+ -p /boot/grub \
+ -O loongarch64-efi \
+ -c $(PKG_BUILD_DIR)/grub-early.cfg \
+ -o $(STAGING_DIR_IMAGE)/grub2/bootloongarch64.efi \
+ boot chain configfile fat linux ls lsefi minicmd part_gpt part_msdos reboot search \
+ search_fs_uuid search_label serial efi_gop all_video gfxterm ext2
+endef
+
define Package/grub2-editenv/install
$(INSTALL_DIR) $(1)/usr/sbin
@@ -206,5 +220,6 @@ $(eval $(call HostBuild))
$(eval $(call BuildPackage,grub2))
$(eval $(call BuildPackage,grub2-efi))
$(eval $(call BuildPackage,grub2-efi-arm))
+$(eval $(call BuildPackage,grub2-efi-loongarch64))
$(eval $(call BuildPackage,grub2-editenv))
$(eval $(call BuildPackage,grub2-bios-setup))