summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2024-04-08 08:05:29 +0200
committerPaul Spooren <mail@aparcar.org>2024-04-08 21:53:05 +0200
commitd997477775bf5447000f1d300a027878b566f5d1 (patch)
tree182215d7e6843ec0d4e02a53d8af567005f0411e /package
parent3ce1e4c3d3da3885c2f42e1aa5bc97e0d421445b (diff)
downloadopenwrt-d997477775bf5447000f1d300a027878b566f5d1.tar.gz
openwrt-d997477775bf5447000f1d300a027878b566f5d1.tar.bz2
openwrt-d997477775bf5447000f1d300a027878b566f5d1.zip
treewide: remove implicit SUBTARGET
Historically it's possible to leave the `SUBTARGETS` undefined and automatically fallback to a "generic" subtarget. This however breaks various downstream scripts which may have expectations around filenames: While some targets with an explicit generic subtarget contain `generic` in the filenames of artifacts, implicit "subtargets" don't. Right now this breaks the CI[1], possibly also scripts using the ImageBuilders. This commit removes all code that support implicit handling of subtargets and instead requires every target to define "SUBTARGETS". [1]: https://github.com/openwrt/openwrt/actions/runs/8592821105/job/23548273630 Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/crypto.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index be9893d453..4a8a283d37 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -11,7 +11,7 @@ CRYPTO_MODULES = \
ALGAPI2=crypto_algapi \
BLKCIPHER2=crypto_blkcipher
-CRYPTO_TARGET = $(BOARD)/$(if $(SUBTARGET),$(SUBTARGET),generic)
+CRYPTO_TARGET = $(BOARD)/$(SUBTARGET)
crypto_confvar=CONFIG_CRYPTO_$(word 1,$(subst =,$(space),$(1)))
crypto_file=$(LINUX_DIR)/crypto/$(word 2,$(subst =,$(space),$(1))).ko