summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorDENG Qingfang <dengqf6@mail2.sysu.edu.cn>2019-09-26 08:13:14 +0800
committerHans Dedecker <dedeckeh@gmail.com>2019-09-28 21:26:53 +0200
commiteddbd68b6d3fa540b2c5e6c0027c08c9f186bfc1 (patch)
treee79ac3799066cd06cdccb41aecc2324b088d1d59 /package
parent1fe1a200d9bbe83437b018757ad75364a6d89b37 (diff)
downloadopenwrt-eddbd68b6d3fa540b2c5e6c0027c08c9f186bfc1.tar.gz
openwrt-eddbd68b6d3fa540b2c5e6c0027c08c9f186bfc1.tar.bz2
openwrt-eddbd68b6d3fa540b2c5e6c0027c08c9f186bfc1.zip
iproute2: update to 5.3.0
Update iproute2 to 5.3.0 Signed-off-by: DENG Qingfang <dengqf6@mail2.sysu.edu.cn>
Diffstat (limited to 'package')
-rw-r--r--package/network/utils/iproute2/Makefile4
-rw-r--r--package/network/utils/iproute2/patches/115-add-config-xtlibdir.patch2
-rw-r--r--package/network/utils/iproute2/patches/170-ip_tiny.patch37
-rw-r--r--package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch8
-rw-r--r--package/network/utils/iproute2/patches/180-drop_FAILED_POLICY.patch6
5 files changed, 31 insertions, 26 deletions
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index cfa6c64cd8..638016e5bc 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=iproute2
-PKG_VERSION:=5.2.0
+PKG_VERSION:=5.3.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
-PKG_HASH:=a5b95dec26353fc71dba9bb403e9343fad2a06bd69fb154a22a2aa2914f74da8
+PKG_HASH:=cb1c1e45993a3bd2438543fd4332d70f1726a6e6ff97dc613a8258c993117b3f
PKG_BUILD_PARALLEL:=1
PKG_BUILD_DEPENDS:=iptables
PKG_LICENSE:=GPL-2.0
diff --git a/package/network/utils/iproute2/patches/115-add-config-xtlibdir.patch b/package/network/utils/iproute2/patches/115-add-config-xtlibdir.patch
index 23e41d7a05..8b3fad6e51 100644
--- a/package/network/utils/iproute2/patches/115-add-config-xtlibdir.patch
+++ b/package/network/utils/iproute2/patches/115-add-config-xtlibdir.patch
@@ -1,6 +1,6 @@
--- a/tc/Makefile
+++ b/tc/Makefile
-@@ -121,6 +121,9 @@ CFLAGS += -DCONFIG_GACT -DCONFIG_GACT_PR
+@@ -123,6 +123,9 @@ CFLAGS += -DCONFIG_GACT -DCONFIG_GACT_PR
ifneq ($(IPT_LIB_DIR),)
CFLAGS += -DIPT_LIB_DIR=\"$(IPT_LIB_DIR)\"
endif
diff --git a/package/network/utils/iproute2/patches/170-ip_tiny.patch b/package/network/utils/iproute2/patches/170-ip_tiny.patch
index fb5a6466e4..7129d4f19e 100644
--- a/package/network/utils/iproute2/patches/170-ip_tiny.patch
+++ b/package/network/utils/iproute2/patches/170-ip_tiny.patch
@@ -1,6 +1,6 @@
--- a/ip/Makefile
+++ b/ip/Makefile
-@@ -16,6 +16,13 @@ RTMONOBJ=rtmon.o
+@@ -17,6 +17,13 @@ RTMONOBJ=rtmon.o
include ../config.mk
@@ -14,7 +14,7 @@
ALLOBJ=$(IPOBJ) $(RTMONOBJ)
SCRIPTS=ifcfg rtpr routel routef
TARGETS=ip rtmon
-@@ -45,7 +52,7 @@ else
+@@ -46,7 +53,7 @@ else
ip: static-syms.o
static-syms.o: static-syms.h
@@ -25,24 +25,24 @@
sed -n '/'$$s'[^ ]* =/{s:.* \([^ ]*'$$s'[^ ]*\) .*:extern char \1[] __attribute__((weak)); if (!strcmp(sym, "\1")) return \1;:;p}' $$files ; \
--- a/ip/ip.c
+++ b/ip/ip.c
-@@ -47,10 +47,16 @@ static void usage(void)
+@@ -48,10 +48,16 @@ static void usage(void)
fprintf(stderr,
- "Usage: ip [ OPTIONS ] OBJECT { COMMAND | help }\n"
- " ip [ -force ] -batch filename\n"
+ "Usage: ip [ OPTIONS ] OBJECT { COMMAND | help }\n"
+ " ip [ -force ] -batch filename\n"
+#ifndef IPROUTE2_TINY
- "where OBJECT := { link | address | addrlabel | route | rule | neigh | ntable |\n"
- " tunnel | tuntap | maddress | mroute | mrule | monitor | xfrm |\n"
- " netns | l2tp | fou | macsec | tcp_metrics | token | netconf | ila |\n"
- " vrf | sr }\n"
+ "where OBJECT := { link | address | addrlabel | route | rule | neigh | ntable |\n"
+ " tunnel | tuntap | maddress | mroute | mrule | monitor | xfrm |\n"
+ " netns | l2tp | fou | macsec | tcp_metrics | token | netconf | ila |\n"
+ " vrf | sr | nexthop }\n"
+#else
-+"where OBJECT := { link | address | route | rule | neigh | tunnel | maddress |\n"
-+" mroute | mrule | monitor | netns | macsec | token | ila |\n"
-+" vrf | sr }\n"
++ "where OBJECT := { link | address | route | rule | neigh | tunnel | maddress |\n"
++ " mroute | mrule | monitor | netns | macsec | token | ila |\n"
++ " vrf | sr }\n"
+#endif
- " OPTIONS := { -V[ersion] | -s[tatistics] | -d[etails] | -r[esolve] |\n"
- " -h[uman-readable] | -iec | -j[son] | -p[retty] |\n"
- " -f[amily] { inet | inet6 | mpls | bridge | link } |\n"
-@@ -72,32 +78,44 @@ static const struct cmd {
+ " OPTIONS := { -V[ersion] | -s[tatistics] | -d[etails] | -r[esolve] |\n"
+ " -h[uman-readable] | -iec | -j[son] | -p[retty] |\n"
+ " -f[amily] { inet | inet6 | mpls | bridge | link } |\n"
+@@ -74,35 +80,49 @@ static const struct cmd {
int (*func)(int argc, char **argv);
} cmds[] = {
{ "address", do_ipaddr },
@@ -86,7 +86,12 @@
+#endif
{ "vrf", do_ipvrf},
{ "sr", do_seg6 },
++#ifndef IPROUTE2_TINY
+ { "nexthop", do_ipnh },
++#endif
{ "help", do_help },
+ { 0 }
+ };
--- a/lib/Makefile
+++ b/lib/Makefile
@@ -3,6 +3,10 @@ include ../config.mk
diff --git a/package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch b/package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch
index 10123a78c3..d3f6a262d6 100644
--- a/package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch
+++ b/package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch
@@ -1,6 +1,6 @@
--- a/tc/Makefile
+++ b/tc/Makefile
-@@ -108,7 +108,7 @@ LDLIBS += -L. -lm
+@@ -110,7 +110,7 @@ LDLIBS += -L. -lm
ifeq ($(SHARED_LIBS),y)
LDLIBS += -ldl
@@ -9,7 +9,7 @@
endif
TCLIB := tc_core.o
-@@ -138,7 +138,7 @@ MODDESTDIR := $(DESTDIR)$(LIBDIR)/tc
+@@ -140,7 +140,7 @@ MODDESTDIR := $(DESTDIR)$(LIBDIR)/tc
all: tc $(TCSO)
tc: $(TCOBJ) $(LIBNETLINK) libtc.a
@@ -18,7 +18,7 @@
libtc.a: $(TCLIB)
$(QUIET_AR)$(AR) rcs $@ $^
-@@ -160,6 +160,7 @@ install: all
+@@ -162,6 +162,7 @@ install: all
clean:
rm -f $(TCOBJ) $(TCLIB) libtc.a tc *.so emp_ematch.yacc.h; \
rm -f emp_ematch.yacc.*
@@ -26,7 +26,7 @@
q_atm.so: q_atm.c
$(QUIET_CC)$(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -shared -fpic -o q_atm.so q_atm.c -latm
-@@ -199,4 +200,15 @@ static-syms.h: $(wildcard *.c)
+@@ -201,4 +202,15 @@ static-syms.h: $(wildcard *.c)
sed -n '/'$$s'[^ ]* =/{s:.* \([^ ]*'$$s'[^ ]*\) .*:extern char \1[] __attribute__((weak)); if (!strcmp(sym, "\1")) return \1;:;p}' $$files ; \
done > $@
diff --git a/package/network/utils/iproute2/patches/180-drop_FAILED_POLICY.patch b/package/network/utils/iproute2/patches/180-drop_FAILED_POLICY.patch
index 5de663f5c6..449d4512fe 100644
--- a/package/network/utils/iproute2/patches/180-drop_FAILED_POLICY.patch
+++ b/package/network/utils/iproute2/patches/180-drop_FAILED_POLICY.patch
@@ -11,7 +11,7 @@ Subject: [PATCH] add support for dropping with FAILED_POLICY
--- a/ip/rtm_map.c
+++ b/ip/rtm_map.c
-@@ -48,6 +48,8 @@ char *rtnl_rtntype_n2a(int id, char *buf
+@@ -54,6 +54,8 @@ char *rtnl_rtntype_n2a(int id, char *buf
return "nat";
case RTN_XRESOLVE:
return "xresolve";
@@ -20,7 +20,7 @@ Subject: [PATCH] add support for dropping with FAILED_POLICY
default:
snprintf(buf, len, "%d", id);
return buf;
-@@ -83,6 +85,8 @@ int rtnl_rtntype_a2n(int *id, char *arg)
+@@ -89,6 +91,8 @@ int rtnl_rtntype_a2n(int *id, char *arg)
res = RTN_UNICAST;
else if (strcmp(arg, "throw") == 0)
res = RTN_THROW;
@@ -31,7 +31,7 @@ Subject: [PATCH] add support for dropping with FAILED_POLICY
if (!end || end == arg || *end || res > 255)
--- a/include/uapi/linux/rtnetlink.h
+++ b/include/uapi/linux/rtnetlink.h
-@@ -228,6 +228,7 @@ enum {
+@@ -235,6 +235,7 @@ enum {
RTN_THROW, /* Not in this table */
RTN_NAT, /* Translate this address */
RTN_XRESOLVE, /* Use external resolver */