summaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorRoman Yeryomin <roman@advem.lv>2020-06-12 21:43:46 +0300
committerPetr Štetiar <ynezz@true.cz>2020-07-11 15:19:53 +0200
commit2ca084ccaae619ac8031e902c66817d021ac6fd5 (patch)
tree821349dcff0400e92ff84659554bc66f4197c481 /rules.mk
parent23de93a5216bf1c24c4e4c71f6cad4455c3cfa2c (diff)
downloadopenwrt-2ca084ccaae619ac8031e902c66817d021ac6fd5.tar.gz
openwrt-2ca084ccaae619ac8031e902c66817d021ac6fd5.tar.bz2
openwrt-2ca084ccaae619ac8031e902c66817d021ac6fd5.zip
build: improve ccache support
Set CCACHE_DIR to $(TOPDIR)/.ccache and CCACHE_BASEDIR to $(TOPDIR). This allows to do clean and dirclean. Cache hit rate for test build after dirclean is ~65%. If CCACHE is enabled stats are printed out at the end of building process. CCACHE_DIR config variable allows to override default, which could be useful when sharing cache with many builds. cacheclean make target allows to clean the cache. Changes from v1: - remove ccache directory using CCACHE_DIR variable - remove ccache leftovers from sdk and toolchain make files - introduce CONFIG_CCACHE_DIR variable - introduce cacheclean make target Signed-off-by: Roman Yeryomin <roman@advem.lv>
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/rules.mk b/rules.mk
index 66ddea2883..e734b4a582 100644
--- a/rules.mk
+++ b/rules.mk
@@ -298,6 +298,9 @@ ifneq ($(CONFIG_CCACHE),)
TARGET_CXX:= ccache_cxx
HOSTCC:= ccache $(HOSTCC)
HOSTCXX:= ccache $(HOSTCXX)
+ export CCACHE_BASEDIR:=$(TOPDIR)
+ export CCACHE_DIR:=$(if $(call qstrip,$(CONFIG_CCACHE_DIR)),$(call qstrip,$(CONFIG_CCACHE_DIR)),$(TOPDIR)/.ccache)
+ export CCACHE_COMPILERCHECK:=%compiler% -dumpmachine; %compiler% -dumpversion
endif
TARGET_CONFIGURE_OPTS = \