summaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2021-01-26 17:16:36 -1000
committerPaul Spooren <mail@aparcar.org>2021-01-26 17:29:49 -1000
commit513f7171a3e509bba54ecc2af2d6259c7cbff221 (patch)
tree9233294aeced1d0d29cb56c28228b0003b1efbc4 /rules.mk
parentff2087d9a9db86c6c5a7fec258fec66bff8e4f9c (diff)
downloadopenwrt-513f7171a3e509bba54ecc2af2d6259c7cbff221.tar.gz
openwrt-513f7171a3e509bba54ecc2af2d6259c7cbff221.tar.bz2
openwrt-513f7171a3e509bba54ecc2af2d6259c7cbff221.zip
rules: fix COMMITCOUNT logic
The newly added $(COMMITCOUNT) variable was wrongly increased by plus one. The addition should have been only added to $(AUTORELEASE) as OpenWrt traditionally starts counting at one rather than zero. $(AUTORELEASE) counts the commits since the last bump, which is zero on the version bump commit itself. This commit increases $(AUTORELEASE) by one while leaving $(COMMITCOUNT) as is. The base-files package is the only package using $(COMMITCOUNT) so far and requires a pseudo commit to keep the PKG_RELEASE correct. A non functional change (Copyright bump) is done in the next commit. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/rules.mk b/rules.mk
index cf4aa30d21..b1b69eabf9 100644
--- a/rules.mk
+++ b/rules.mk
@@ -421,7 +421,7 @@ $(shell \
if [ -n "$$last_bump" ]; then \
echo -n $$(($$(git rev-list --count "$$last_bump..HEAD" .) + 1)); \
else \
- echo -n $$(($$(git rev-list --count HEAD .) + 1)); \
+ git rev-list --count HEAD .; \
fi; \
else \
secs="$$(($(SOURCE_DATE_EPOCH) % 86400))"; \