summaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorPaul Fertser <fercerpav@gmail.com>2023-01-20 18:25:13 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2023-03-05 17:48:31 +0100
commit5a1eb3bb2c27ede3046bb2977008c74a04681db9 (patch)
tree7a8d882bf98f3d94c8ff64f508c579df1e9989fb /rules.mk
parent4448b27930526e700d2fcb882bad2fd10aa17918 (diff)
downloadopenwrt-5a1eb3bb2c27ede3046bb2977008c74a04681db9.tar.gz
openwrt-5a1eb3bb2c27ede3046bb2977008c74a04681db9.tar.bz2
openwrt-5a1eb3bb2c27ede3046bb2977008c74a04681db9.zip
Remove ccache wrappers
These wrappers are not needed as CC doesn't need to be a single word. a53b084e497a9f1629a2caada833ebe14a6838b7 which introduced the wrappers doesn't explain why they were really needed and why only for the target and not for the host. Moreover, name of the wrappers breaks a ccache assumption: since v4.0-3-g6a92b4cd3a67 it has special handling for "chained" invocation such as "ccache ccache gcc" where it skips all the "ccache*" names in the middle and proceeds to run as if it was started as "ccache gcc"[1][2]. This becomes important when a build system sees ccache in the PATH and automatically enables it by prepending to CC. An example of such a system would be autosetup as used by jimtcl. With the wrappers it breaks as the command line ends up being just "ccache -Os..." because "ccache_cc" gets skipped as it starts with "ccache". [1] https://github.com/ccache/ccache/blob/master/src/ccache.cpp#L2105 [2] https://github.com/ccache/ccache/blob/master/src/Util.cpp#L802 Reported-by: Karl Palsson <karlp@etactica.com> Signed-off-by: Paul Fertser <fercerpav@gmail.com>
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/rules.mk b/rules.mk
index 3d151338af..a2f5bcca4b 100644
--- a/rules.mk
+++ b/rules.mk
@@ -283,8 +283,8 @@ export HOSTCC_NOCACHE
export HOSTCXX_NOCACHE
ifneq ($(CONFIG_CCACHE),)
- TARGET_CC:= ccache_cc
- TARGET_CXX:= ccache_cxx
+ TARGET_CC:= ccache $(TARGET_CC)
+ TARGET_CXX:= ccache $(TARGET_CXX)
HOSTCC:= ccache $(HOSTCC)
HOSTCXX:= ccache $(HOSTCXX)
export CCACHE_BASEDIR:=$(TOPDIR)