summaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-03 09:06:03 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-03 09:06:03 +0000
commit5b4bfbd6d4e17f601cbf66d998cc788a62ac3f4d (patch)
treeaa6ae991d83d2f7ff5f6bcd7a237da7b4cc133f2 /rules.mk
parent8dc7ced4d4df85bc6cc77b625d54150a64f31bc6 (diff)
downloadopenwrt-5b4bfbd6d4e17f601cbf66d998cc788a62ac3f4d.tar.gz
openwrt-5b4bfbd6d4e17f601cbf66d998cc788a62ac3f4d.tar.bz2
openwrt-5b4bfbd6d4e17f601cbf66d998cc788a62ac3f4d.zip
move TARGET_* flags from ./include/package-default.mk to ./rules.mk, remove EXTRA_* flags but still use them in configure and make
SVN-Revision: 8592
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk6
1 files changed, 2 insertions, 4 deletions
diff --git a/rules.mk b/rules.mk
index b817537826..eb62112a82 100644
--- a/rules.mk
+++ b/rules.mk
@@ -56,6 +56,8 @@ endif
TARGET_PATH:=$(TOOLCHAIN_DIR)/bin:$(STAGING_DIR_HOST)/bin:$(STAGING_DIR)/usr/bin:$(PATH)
TARGET_CFLAGS:=$(TARGET_OPTIMIZATION) -fhonour-copts
+TARGET_CPPFLAGS:=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
+TARGET_LDFLAGS:=-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
export PATH:=$(TARGET_PATH)
@@ -82,10 +84,6 @@ ifneq ($(CONFIG_CCACHE),)
TARGET_CC:= ccache $(TARGET_CC)
endif
-EXTRA_CPPFLAGS := -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
-EXTRA_CFLAGS := $(EXTRA_CPPFLAGS)
-EXTRA_LDFLAGS := -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
-
TARGET_CONFIGURE_OPTS:= \
AR=$(TARGET_CROSS)ar \
AS="$(TARGET_CC) -c $(TARGET_CFLAGS)" \