summaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2023-10-19 17:39:24 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-10-20 16:13:56 +0200
commit987458c2e1bb9afc3d635aca3c6e8942ed2e95f6 (patch)
tree6f646275e4bd430e41e910c65dd6f3cbf8caf95c /rules.mk
parent28420cd67bc4c0fe5974ac0336528aea3a443b98 (diff)
downloadopenwrt-987458c2e1bb9afc3d635aca3c6e8942ed2e95f6.tar.gz
openwrt-987458c2e1bb9afc3d635aca3c6e8942ed2e95f6.tar.bz2
openwrt-987458c2e1bb9afc3d635aca3c6e8942ed2e95f6.zip
rules.mk: make toolchain dirs define more consistent
Make toolchain dirs define more consistent between internal and external toolchains. Make use of specific dirs also for intenral toolchain and generilize include and lib inclusion. Also set TOOLCHAIN_ROOT_DIR for internal toolchain as this is what packages should use to reference staging toolchain directory. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk28
1 files changed, 14 insertions, 14 deletions
diff --git a/rules.mk b/rules.mk
index f298c8d794..6f05047f26 100644
--- a/rules.mk
+++ b/rules.mk
@@ -184,14 +184,14 @@ ifndef DUMP
-include $(TOOLCHAIN_DIR)/info.mk
export GCC_HONOUR_COPTS:=0
TARGET_CROSS:=$(if $(TARGET_CROSS),$(TARGET_CROSS),$(OPTIMIZE_FOR_CPU)-openwrt-linux$(if $(TARGET_SUFFIX),-$(TARGET_SUFFIX))-)
+ TOOLCHAIN_ROOT_DIR:=$(TOPDIR)/staging_dir/$(TOOLCHAIN_DIR_NAME)
+ TOOLCHAIN_BIN_DIRS:=$(TOOLCHAIN_ROOT_DIR)/bin
+ TOOLCHAIN_INC_DIRS:=$(TOOLCHAIN_ROOT_DIR)/usr/include $(TOOLCHAIN_ROOT_DIR)/include
+ TOOLCHAIN_LIB_DIRS:=$(TOOLCHAIN_ROOT_DIR)/usr/lib $(TOOLCHAIN_ROOT_DIR)/lib
TARGET_CFLAGS+= -fhonour-copts
- TARGET_CPPFLAGS+= -I$(TOOLCHAIN_DIR)/usr/include
ifeq ($(CONFIG_USE_MUSL),y)
- TARGET_CPPFLAGS+= -I$(TOOLCHAIN_DIR)/include/fortify
+ TOOLCHAIN_INC_DIRS+= $(TOOLCHAIN_DIR)/include/fortify
endif
- TARGET_CPPFLAGS+= -I$(TOOLCHAIN_DIR)/include
- TARGET_LDFLAGS+= -L$(TOOLCHAIN_DIR)/usr/lib -L$(TOOLCHAIN_DIR)/lib
- TARGET_PATH:=$(TOOLCHAIN_DIR)/bin:$(TARGET_PATH)
else
ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
TARGET_CROSS:=$(call qstrip,$(CONFIG_TOOLCHAIN_PREFIX))
@@ -199,17 +199,17 @@ ifndef DUMP
TOOLCHAIN_BIN_DIRS:=$(patsubst ./%,$(TOOLCHAIN_ROOT_DIR)/%,$(call qstrip,$(CONFIG_TOOLCHAIN_BIN_PATH)))
TOOLCHAIN_INC_DIRS:=$(patsubst ./%,$(TOOLCHAIN_ROOT_DIR)/%,$(call qstrip,$(CONFIG_TOOLCHAIN_INC_PATH)))
TOOLCHAIN_LIB_DIRS:=$(patsubst ./%,$(TOOLCHAIN_ROOT_DIR)/%,$(call qstrip,$(CONFIG_TOOLCHAIN_LIB_PATH)))
- ifneq ($(TOOLCHAIN_BIN_DIRS),)
- TARGET_PATH:=$(subst $(space),:,$(TOOLCHAIN_BIN_DIRS)):$(TARGET_PATH)
- endif
- ifneq ($(TOOLCHAIN_INC_DIRS),)
- TARGET_CPPFLAGS+= $(patsubst %,-I%,$(TOOLCHAIN_INC_DIRS))
- endif
- ifneq ($(TOOLCHAIN_LIB_DIRS),)
- TARGET_LDFLAGS+= $(patsubst %,-L%,$(TOOLCHAIN_LIB_DIRS))
- endif
endif
endif
+ ifneq ($(TOOLCHAIN_BIN_DIRS),)
+ TARGET_PATH:=$(subst $(space),:,$(TOOLCHAIN_BIN_DIRS)):$(TARGET_PATH)
+ endif
+ ifneq ($(TOOLCHAIN_INC_DIRS),)
+ TARGET_CPPFLAGS+= $(patsubst %,-I%,$(TOOLCHAIN_INC_DIRS))
+ endif
+ ifneq ($(TOOLCHAIN_LIB_DIRS),)
+ TARGET_LDFLAGS+= $(patsubst %,-L%,$(TOOLCHAIN_LIB_DIRS))
+ endif
endif
TARGET_LINKER?=bfd