summaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2020-11-27 09:56:16 +0100
committerPetr Štetiar <ynezz@true.cz>2020-11-27 14:46:13 +0100
commite52d0487e88c3c8c57e1310d1a02b18eae0d142e (patch)
treecb9152f7854131d575c0c8b3b30bb5435292b959 /rules.mk
parente5ba6e9c28ad3ee8624a5df0e056cffead765779 (diff)
downloadopenwrt-e52d0487e88c3c8c57e1310d1a02b18eae0d142e.tar.gz
openwrt-e52d0487e88c3c8c57e1310d1a02b18eae0d142e.tar.bz2
openwrt-e52d0487e88c3c8c57e1310d1a02b18eae0d142e.zip
rules.mk: remove redundant target flags
We're patching the GCC specs [1], [2] to implicitly add $STAGING_DIR/usr/lib to the linker and $STAGING_DIR/usr/include to the CPP flags. There is no need to globally pass these as -I and -L flags respectively. 1. https://git.openwrt.org/?p=openwrt/openwrt.git;a=blob;f=toolchain/gcc/final/Makefile#l86 2. https://git.openwrt.org/?p=openwrt/openwrt.git;a=blob;f=scripts/patch-specs.sh#l37 Ref: https://patchwork.ozlabs.org/project/openwrt/patch/20200820060637.533293-1-a.heider@gmail.com/#2511505 Suggested-by: Jo-Philipp Wich <jo@mein.io> Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk2
1 files changed, 0 insertions, 2 deletions
diff --git a/rules.mk b/rules.mk
index 671c8bdad8..adb103d81f 100644
--- a/rules.mk
+++ b/rules.mk
@@ -174,8 +174,6 @@ TARGET_CFLAGS:=$(TARGET_OPTIMIZATION)$(if $(CONFIG_DEBUG), -g3) $(call qstrip,$(
TARGET_CXXFLAGS = $(TARGET_CFLAGS)
TARGET_ASFLAGS_DEFAULT = $(TARGET_CFLAGS)
TARGET_ASFLAGS = $(TARGET_ASFLAGS_DEFAULT)
-TARGET_CPPFLAGS:=-I$(STAGING_DIR)/usr/include
-TARGET_LDFLAGS:=-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
ifneq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
LIBGCC_S_PATH=$(realpath $(wildcard $(call qstrip,$(CONFIG_LIBGCC_ROOT_DIR))/$(call qstrip,$(CONFIG_LIBGCC_FILE_SPEC))))
LIBGCC_S=$(if $(LIBGCC_S_PATH),-L$(dir $(LIBGCC_S_PATH)) -lgcc_s)