summaryrefslogtreecommitdiffstats
path: root/scripts/config
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-08-25 09:16:03 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-08-25 09:16:03 +0000
commit32ab3b9692d4c875ed428c2713f4c95701734d32 (patch)
treef365bec827d9d90daec75a5e5447dc5f8d22dfb8 /scripts/config
parent241242cf7452a81acc1d293398e49dc7daf044a4 (diff)
downloadopenwrt-32ab3b9692d4c875ed428c2713f4c95701734d32.tar.gz
openwrt-32ab3b9692d4c875ed428c2713f4c95701734d32.tar.bz2
openwrt-32ab3b9692d4c875ed428c2713f4c95701734d32.zip
do not check for a specific Cygwin version, rather check the operating system name directly, thanks AndyI
SVN-Revision: 17394
Diffstat (limited to 'scripts/config')
-rw-r--r--scripts/config/lxdialog/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/scripts/config/lxdialog/Makefile b/scripts/config/lxdialog/Makefile
index 3758637ccf..74ee942cd6 100644
--- a/scripts/config/lxdialog/Makefile
+++ b/scripts/config/lxdialog/Makefile
@@ -12,8 +12,7 @@ LIBS := $(shell sh check-lxdialog.sh -ldflags gcc)
OS := $(shell uname -s)
ifeq ($(strip $(OS)),OpenBSD)
LIBS := -lncurses
-endif
-ifeq ($(strip $(OS)),CYGWIN_NT-5.1)
+ifeq ($(shell uname -o),Cygwin)
LIBS := -lncurses
endif
always := $(hostprogs-y) dochecklxdialog