summaryrefslogtreecommitdiffstats
path: root/scripts/ext-toolchain.sh
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2022-07-17 17:56:36 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2022-07-24 19:53:44 +0200
commit75311977f5ff64b491cb57ac713d75e0e410d786 (patch)
tree627f191b156eec27fdf0e982150d6ef9c9501287 /scripts/ext-toolchain.sh
parentddeabc75ebe3151ff7da302cb1aae702b3ad7eba (diff)
downloadopenwrt-75311977f5ff64b491cb57ac713d75e0e410d786.tar.gz
openwrt-75311977f5ff64b491cb57ac713d75e0e410d786.tar.bz2
openwrt-75311977f5ff64b491cb57ac713d75e0e410d786.zip
scripts: ext-toolchain: add support for info.mk in probe_cc
Openwrt generate info.mk that contains the libc type. For probe_cc check if the file exist and parse directly it for LIBC type. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'scripts/ext-toolchain.sh')
-rwxr-xr-xscripts/ext-toolchain.sh7
1 files changed, 7 insertions, 0 deletions
diff --git a/scripts/ext-toolchain.sh b/scripts/ext-toolchain.sh
index 1ef3f42c50..1f8eca3076 100755
--- a/scripts/ext-toolchain.sh
+++ b/scripts/ext-toolchain.sh
@@ -463,6 +463,13 @@ probe_cpp() {
}
probe_libc() {
+ if [ -f $TOOLCHAIN/info.mk ]; then
+ LIBC_TYPE=$(grep LIBC_TYPE $TOOLCHAIN/info.mk | sed 's/LIBC_TYPE=//')
+ return 0
+ fi
+
+ echo "Warning! Can't find info.mk, trying to detect with alternative way."
+
if [ -z "$LIBC_TYPE" ]; then
if test_uclibc; then
LIBC_TYPE="uclibc"