summaryrefslogtreecommitdiffstats
path: root/scripts/json_overview_image_info.py
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-04-08 10:17:01 -1000
committerDaniel Golle <daniel@makrotopia.org>2020-04-14 23:16:55 +0100
commit14cbd8fb2dd8c81bad06d3c3bb45213685c19c98 (patch)
tree8e6ecc0c1c045c401ea0125a2262bbeafa7e7172 /scripts/json_overview_image_info.py
parent0bea89a1d0f98af102cef32d6a8302bc28606180 (diff)
downloadopenwrt-14cbd8fb2dd8c81bad06d3c3bb45213685c19c98.tar.gz
openwrt-14cbd8fb2dd8c81bad06d3c3bb45213685c19c98.tar.bz2
openwrt-14cbd8fb2dd8c81bad06d3c3bb45213685c19c98.zip
scripts: JSON merge don't crash if no JSON found
The JSON `WORK_DIR` ($(KDIR)/json_info_files) is only created if the new image generation methods from `image.mk` are used. However some targets like `armvirt` do not use it yet, so the folder is never created. The `json_overview_image_info.py` script used to raise an error if the given `WORK_DIR` isn't a folder, however it should just notify about missing JSON files. This patch removes the Python assert and exists with code 0 even if no JSON files were found, as this is not necessarily an error but simply not yet implemented. Using `glob` on an not existing `Path` results in an empty list, therefore the for loop won't run. Signed-off-by: Paul Spooren <mail@aparcar.org> CC: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'scripts/json_overview_image_info.py')
-rwxr-xr-xscripts/json_overview_image_info.py2
1 files changed, 0 insertions, 2 deletions
diff --git a/scripts/json_overview_image_info.py b/scripts/json_overview_image_info.py
index 5ed829249b..a1418e366d 100755
--- a/scripts/json_overview_image_info.py
+++ b/scripts/json_overview_image_info.py
@@ -15,8 +15,6 @@ assert getenv("WORK_DIR"), "$WORK_DIR required"
work_dir = Path(getenv("WORK_DIR"))
-assert work_dir.is_dir(), "$WORK_DIR not a directory"
-
output = {}
for json_file in work_dir.glob("*.json"):