summaryrefslogtreecommitdiffstats
path: root/scripts/target-metadata.pl
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2019-03-27 22:52:05 +0100
committerDaniel Golle <daniel@makrotopia.org>2019-03-27 22:53:14 +0100
commit7204736076b277977388ad43cd69f221a377ed7e (patch)
treee7b181d6814e4c95cce1614458f763c491eebbef /scripts/target-metadata.pl
parent1e8bb50b9324cb368fe5b2bd916c98b8d8517be5 (diff)
downloadopenwrt-7204736076b277977388ad43cd69f221a377ed7e.tar.gz
openwrt-7204736076b277977388ad43cd69f221a377ed7e.tar.bz2
openwrt-7204736076b277977388ad43cd69f221a377ed7e.zip
IB: fix generating .profile.mk for profiles without metadata
Fixes d6fa04a437 ("IB: include SUPPORTED_DEVICES in 'make info' output") Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'scripts/target-metadata.pl')
-rwxr-xr-xscripts/target-metadata.pl2
1 files changed, 1 insertions, 1 deletions
diff --git a/scripts/target-metadata.pl b/scripts/target-metadata.pl
index 4e4bc73d91..bd73ee910c 100755
--- a/scripts/target-metadata.pl
+++ b/scripts/target-metadata.pl
@@ -423,7 +423,7 @@ sub gen_profile_mk() {
foreach my $profile (@{$cur->{profiles}}) {
print $profile->{id}.'_NAME:='.$profile->{name}."\n";
print $profile->{id}.'_HAS_IMAGE_METADATA:='.$profile->{has_image_metadata}."\n";
- if (@{$profile->{supported_devices}} > 0) {
+ if (defined($profile->{supported_devices}) and @{$profile->{supported_devices}} > 0) {
print $profile->{id}.'_SUPPORTED_DEVICES:='.join(' ', @{$profile->{supported_devices}})."\n";
}
print $profile->{id}.'_PACKAGES:='.join(' ', @{$profile->{packages}})."\n";