summaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2024-05-14 12:36:59 +0200
committerPaul Spooren <mail@aparcar.org>2024-05-17 23:21:26 +0300
commitd788ab376f859164df84e2054cbbbb0921943c5b (patch)
tree80d4b0c9cc001aa3a6f0a7a84beb6f40666d5dde /scripts
parent3e5a23639f53f6a5e969f7c243b534f31399fe8a (diff)
downloadopenwrt-d788ab376f859164df84e2054cbbbb0921943c5b.tar.gz
openwrt-d788ab376f859164df84e2054cbbbb0921943c5b.tar.bz2
openwrt-d788ab376f859164df84e2054cbbbb0921943c5b.zip
build: add APK package build capabilities
A new option called `USE_APK` is added which generated APK packages (.apk) instead of OPKG packages (.ipk). Some features like fstools `snapshot` command are not yet ported Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/feeds4
-rwxr-xr-xscripts/package-metadata.pl2
2 files changed, 3 insertions, 3 deletions
diff --git a/scripts/feeds b/scripts/feeds
index 7d5b83e081..b5b943c70b 100755
--- a/scripts/feeds
+++ b/scripts/feeds
@@ -865,7 +865,7 @@ sub feed_config() {
printf "\t\tdepends on PER_FEED_REPO\n";
printf "\t\tdefault y\n" if $installed;
printf "\t\thelp\n";
- printf "\t\t Enable the \\\"%s\\\" feed in opkg distfeeds.conf.\n", $feed->[1];
+ printf "\t\t Enable the \\\"%s\\\" feed in opkg distfeeds.conf and apk repositories.\n", $feed->[1];
printf "\t\t Say M to add the feed commented out.\n";
printf "\n";
}
@@ -884,7 +884,7 @@ Commands:
-s : List of feed names and their URL.
-r <feedname>: List packages of specified feed.
-d <delimiter>: Use specified delimiter to distinguish rows (default: spaces)
- -f : List feeds in feeds.conf compatible format (when using -s).
+ -f : List feeds in opkg feeds.conf compatible format (when using -s).
install [options] <package>: Install a package
Options:
diff --git a/scripts/package-metadata.pl b/scripts/package-metadata.pl
index a46f819ab5..2c7d3c624b 100755
--- a/scripts/package-metadata.pl
+++ b/scripts/package-metadata.pl
@@ -373,7 +373,7 @@ sub and_condition($) {
sub gen_condition ($) {
my $condition = shift;
- # remove '!()', just as include/package-ipkg.mk does
+ # remove '!()', just as include/package-pack.mk does
$condition =~ s/[()!]//g;
return join("", map(and_condition($_), split('\|\|', $condition)));
}