summaryrefslogtreecommitdiffstats
path: root/target/imagebuilder/files
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2024-10-24 20:32:42 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2024-10-29 00:07:52 +0100
commit1c211e778180068b348cffaa668b37156bb8e5fd (patch)
tree590b171b1b09ff13eb504e5e08b209e699817bc3 /target/imagebuilder/files
parent27c76121d8cf6d78bbe8ce163cb02fb60baaa61e (diff)
downloadopenwrt-1c211e778180068b348cffaa668b37156bb8e5fd.tar.gz
openwrt-1c211e778180068b348cffaa668b37156bb8e5fd.tar.bz2
openwrt-1c211e778180068b348cffaa668b37156bb8e5fd.zip
imagebuilder: correctly export PACKAGE_DIR and PACKAGE_DIR_ALL
Correctly export PACKAGE_DIR and PACKAGE_DIR_ALL so that they won't be reset on internal call of rules.mk Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'target/imagebuilder/files')
-rw-r--r--target/imagebuilder/files/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index 7d01bc0e42..024002666a 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -83,9 +83,9 @@ help: FORCE
# override variables from rules.mk
-PACKAGE_DIR:=$(TOPDIR)/packages
+export PACKAGE_DIR:=$(TOPDIR)/packages
LISTS_DIR:=$(subst $(space),/,$(patsubst %,..,$(subst /,$(space),$(TARGET_DIR))))$(DL_DIR)
-PACKAGE_DIR_ALL:=$(TOPDIR)/packages
+export PACKAGE_DIR_ALL:=$(TOPDIR)/packages
export OPKG_KEYS:=$(TOPDIR)/keys
OPKG:=$(call opkg,$(TARGET_DIR)) \