summaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2024-11-08 10:37:16 +0100
committerPaul Spooren <mail@aparcar.org>2024-11-09 16:46:44 +0100
commit12a73078692da9d6b2e599d4cd4eb8a18daf3c63 (patch)
tree659cf572515df9aace068114535977fe540b7f2b /target/imagebuilder
parent15b7994c0198bef0b59bc78880529017387a239d (diff)
downloadopenwrt-12a73078692da9d6b2e599d4cd4eb8a18daf3c63.tar.gz
openwrt-12a73078692da9d6b2e599d4cd4eb8a18daf3c63.tar.bz2
openwrt-12a73078692da9d6b2e599d4cd4eb8a18daf3c63.zip
imagebuilder: init APK dirs every time
The `--initdb` command creates basic folders required by APK, previoiusly it would only run a single time when package_index is actually called. Since the function isn't called if nothing changes, `--initdb` doesn't initialize the rootfs again. This commit moves it to package_reload, which runs every time. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/files/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index 914609ada1..72b36b0862 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -181,7 +181,6 @@ ifeq ($(CONFIG_USE_APK),)
) >/dev/null 2>/dev/null
$(OPKG) update >&2 || true
else
- $(APK) add --initdb
(cd $(PACKAGE_DIR); $(APK) mkndx \
$(if $(CONFIG_SIGNATURE_CHECK), --keys-dir $(APK_KEYS) --sign $(BUILD_KEY_APK_SEC)) \
--allow-untrusted --output packages.adb *.apk) >/dev/null 2>/dev/null || true
@@ -200,6 +199,7 @@ ifeq ($(CONFIG_USE_APK),)
$(OPKG) update >&2 || true; \
fi
else
+ $(APK) add --initdb
if [ -d "$(PACKAGE_DIR)" ] && ( \
[ ! -f "$(PACKAGE_DIR)/packages.adb" ] || \
[ "`find $(PACKAGE_DIR) -cnewer $(PACKAGE_DIR)/packages.adb`" ] ); then \