summaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2024-11-19 14:36:17 +0100
committerRobert Marko <robimarko@gmail.com>2024-11-19 19:52:03 +0100
commit1c308bad5445df91d901d8389bfe31c888d0e8c9 (patch)
tree727c66d8813cc171c3e5df97e164e583d7bd3eb8 /target/imagebuilder
parent0d0a5eb4b590f6f1f50040a56a35179886b40e62 (diff)
downloadopenwrt-1c308bad5445df91d901d8389bfe31c888d0e8c9.tar.gz
openwrt-1c308bad5445df91d901d8389bfe31c888d0e8c9.tar.bz2
openwrt-1c308bad5445df91d901d8389bfe31c888d0e8c9.zip
imagebuilder: fix APK architecture setting
Currently, when "apk add --initdb" is called it will populate the /etc/apk/arch file with the architecture of the host instead of the target package architecture and this will then make it impossible for new packages to be installed on the device as the target architecture will not match after APK is updated to include [1]. So, lets use override the architecture by passing the target package one by using the "--arch" argument to "apk add". [1] https://gitlab.alpinelinux.org/alpine/apk-tools/-/commit/c1a3e69f24e235fc78f4dddb1f85fdf281464446 Fixes: #16953 Link: https://github.com/openwrt/openwrt/pull/17015 Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/files/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index d1502d40c1..2c6e26e4ee 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -200,7 +200,7 @@ ifeq ($(CONFIG_USE_APK),)
$(OPKG) update >&2 || true; \
fi
else
- $(APK) add --initdb
+ $(APK) add --arch $(ARCH_PACKAGES) --initdb
if [ -d "$(PACKAGE_DIR)" ] && ( \
[ ! -f "$(PACKAGE_DIR)/packages.adb" ] || \
[ "`find $(PACKAGE_DIR) -cnewer $(PACKAGE_DIR)/packages.adb`" ] ); then \
@@ -227,7 +227,7 @@ ifeq ($(CONFIG_USE_APK),)
$(OPKG) install $(wildcard $(PACKAGE_DIR)/kernel_*.ipk)
$(OPKG) install $(BUILD_PACKAGES)
else
- $(APK) add --no-scripts $(BUILD_PACKAGES)
+ $(APK) add --arch $(ARCH_PACKAGES) --no-scripts $(BUILD_PACKAGES)
endif
prepare_rootfs: FORCE