summaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2024-01-25 10:25:06 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2024-03-29 20:00:27 +0100
commit27d227b6828f5b211e68aa633f82c94c65f27d63 (patch)
tree2933b082118749b7c481756067cd0c1b70629d52 /target/imagebuilder
parent163c3d0bde28664058656ce1c2bd97f80e4dbe2d (diff)
downloadopenwrt-27d227b6828f5b211e68aa633f82c94c65f27d63.tar.gz
openwrt-27d227b6828f5b211e68aa633f82c94c65f27d63.tar.bz2
openwrt-27d227b6828f5b211e68aa633f82c94c65f27d63.zip
imagebuilder: check if BOARD is located in the feeds sub directory
Fixes the regression so that targets that were installed via a feed can also be build again with the Image Builder. Fixes: 84ec8c4 ("imagebuilder: copy from buildroot only target/linux") Signed-off-by: Florian Eckert <fe@dev.tdt.de> Tested-by: Thomas Richard <thomas.richard@bootlin.com>
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/target/imagebuilder/Makefile b/target/imagebuilder/Makefile
index c3b6c9c10c..799ac3be55 100644
--- a/target/imagebuilder/Makefile
+++ b/target/imagebuilder/Makefile
@@ -80,7 +80,13 @@ endif
$(CP) -L $(TOPDIR)/target/linux/Makefile $(PKG_BUILD_DIR)/target/linux
$(CP) -L $(TOPDIR)/target/linux/generic $(PKG_BUILD_DIR)/target/linux
- $(CP) -L $(TOPDIR)/target/linux/$(BOARD) $(PKG_BUILD_DIR)/target/linux
+ # check if board is installed from a feeds subdirectory
+ if [ -d $(TOPDIR)/target/linux/feeds/$(BOARD) ]; then \
+ mkdir -p $(PKG_BUILD_DIR)/target/linux/feeds; \
+ $(CP) -L $(TOPDIR)/target/linux/feeds/$(BOARD) $(PKG_BUILD_DIR)/target/linux/feeds; \
+ else \
+ $(CP) -L $(TOPDIR)/target/linux/$(BOARD) $(PKG_BUILD_DIR)/target/linux; \
+ fi
if [ -d $(TOPDIR)/staging_dir/host/lib/grub ]; then \
$(CP) $(TOPDIR)/staging_dir/host/lib/grub/ $(PKG_BUILD_DIR)/staging_dir/host/lib; \
fi