summaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2024-05-19 14:58:11 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2024-05-19 14:58:11 +0200
commit5d37d8dc824f4fdef690b80ceae1bde6a6f16913 (patch)
tree3588a79f43329c98f90e5c0b437ef3e11a50058c /target/imagebuilder
parent65c1f0d433e89c794a6d22dbe474666c241f9e7b (diff)
downloadopenwrt-5d37d8dc824f4fdef690b80ceae1bde6a6f16913.tar.gz
openwrt-5d37d8dc824f4fdef690b80ceae1bde6a6f16913.tar.bz2
openwrt-5d37d8dc824f4fdef690b80ceae1bde6a6f16913.zip
imagebuilder: fix multiple issue with manifest and sign keys handling
Fix multiple issue with manifest handling where APK was hardcoded and fix a logic error where (TODO) APK _check_keys was called for the OPKG codepath instead of correctly calling for the APK codepath. Fixes: d788ab376f85 ("build: add APK package build capabilities") Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/files/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index c032306c8e..7d01bc0e42 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -159,7 +159,11 @@ _call_manifest: FORCE
mkdir -p $(TARGET_DIR) $(BIN_DIR) $(TMP_DIR) $(DL_DIR)
$(MAKE) package_reload >/dev/null
$(MAKE) package_install >/dev/null
+ifeq ($(CONFIG_USE_APK),)
+ $(OPKG) list-installed $(if $(STRIP_ABI),--strip-abi)
+else
$(APK) list --quiet --manifest --no-network
+endif
package_index: FORCE
@echo >&2
@@ -202,7 +206,11 @@ endif
package_list: FORCE
@$(MAKE) -s package_reload
+ifeq ($(CONFIG_USE_APK),)
+ @$(OPKG) list --size 2>/dev/null
+else
@$(APK) list --size 2>/dev/null
+endif
package_install: FORCE
@echo
@@ -277,8 +285,6 @@ endif
_check_keys: FORCE
ifeq ($(CONFIG_USE_APK),)
- # TODO
-else
ifneq ($(CONFIG_SIGNATURE_CHECK),)
@if [ ! -s $(BUILD_KEY) -o ! -s $(BUILD_KEY).pub ]; then \
echo Generate local signing keys... >&2; \
@@ -294,6 +300,8 @@ ifneq ($(CONFIG_SIGNATURE_CHECK),)
-s $(BUILD_KEY); \
fi
endif
+else
+ # TODO
endif
image: