summaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2021-08-18 17:19:15 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2023-01-06 18:44:44 +0100
commit7b60dba954e310261aef7da3fe252e841721c88d (patch)
tree64c55b1179422f9729f2be1ed8f36dcf3bd760c6 /target/imagebuilder
parentf193f2d1a007f215b0c5619f14dc4ca6b579bfb6 (diff)
downloadopenwrt-7b60dba954e310261aef7da3fe252e841721c88d.tar.gz
openwrt-7b60dba954e310261aef7da3fe252e841721c88d.tar.bz2
openwrt-7b60dba954e310261aef7da3fe252e841721c88d.zip
target/imagebuilder: add depends target to show all package that gets installed
This commits adds the makefile targets `depends` this wrapper is a call to `opkg depends`. This command shows which runtime dependencies exist if this package is installed into the image. Signed-off-by: Florian Eckert <fe@dev.tdt.de>
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/files/Makefile18
1 files changed, 17 insertions, 1 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index 3329fe70aa..79e6826c10 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -35,6 +35,7 @@ Available Commands:
info: Show a list of available target profiles
clean: Remove images and temporary build files
image: Build an image (see below for more information).
+ package_depends: Show installation dependency of the package
Building images:
By default 'make image' will create an image with the default
@@ -57,6 +58,12 @@ Print manifest:
make manifest PACKAGES="<pkg1> [<pkg2> [<pkg3> ...]]" # include extra packages
make manifest STRIP_ABI=1 # remove ABI version from printed package names
+package_depends:
+ List "all" packages dependency of the package
+ You can use the following parameters:
+
+ make package_depends PACKAGE="<pkg>"
+
endef
$(eval $(call shexport,Helptext))
@@ -263,4 +270,13 @@ endif
@$(MAKE) -s package_reload
@$(OPKG) whatdepends -A $(PACKAGE)
-.SILENT: help info image manifest whatdepends
+package_depends: FORCE
+ifeq ($(PACKAGE),)
+ @echo 'Variable `PACKAGE` is not set but required by `package_depends`'
+ @exit 1
+endif
+ @$(MAKE) -s package_reload
+ @$(OPKG) depends -A $(PACKAGE)
+
+
+.SILENT: help info image manifest whatdepends package_depends