summaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2024-07-16 19:00:29 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2024-07-16 19:05:18 +0200
commitc85348d9abf4b89d37a7fa134cf6424bdf16787f (patch)
treeb3a1a0b181e069868da59fa76a5529992e95f22d /target/imagebuilder
parentb4f1deab9041583e7c350df4a490f6c8d999614b (diff)
downloadopenwrt-c85348d9abf4b89d37a7fa134cf6424bdf16787f.tar.gz
openwrt-c85348d9abf4b89d37a7fa134cf6424bdf16787f.tar.bz2
openwrt-c85348d9abf4b89d37a7fa134cf6424bdf16787f.zip
imagebuilder: remove initramfs image files
Initramfs images are not supported by imagebuilder. With recent changes to support Per Device Rootfs, we now generate an image and a vmlinux for each Rootfs and these additional files are all shipped in the imagebuilder tar. Drop these new file and any vmlinux-initramfs as they are not used and increase the final size of the imagebuilder archive. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/imagebuilder/Makefile b/target/imagebuilder/Makefile
index 7fd2aa0920..7127df5ebc 100644
--- a/target/imagebuilder/Makefile
+++ b/target/imagebuilder/Makefile
@@ -112,6 +112,9 @@ endif
-cp $(LINUX_DIR)/.config $(IB_LDIR)/
rm -f $(IB_KDIR)/root.*
rm -f $(IB_KDIR)/vmlinux.debug
+ # remove any file for initramfs and Per Device Rootfs initramfs files
+ rm -f $(IB_KDIR)/vmlinux-initramfs*
+ rm -f $(IB_KDIR)/Image-initramfs*
if [ -x $(LINUX_DIR)/scripts/dtc/dtc ]; then \
$(INSTALL_DIR) $(IB_LDIR)/scripts/dtc; \
$(INSTALL_BIN) $(LINUX_DIR)/scripts/dtc/dtc $(IB_LDIR)/scripts/dtc/dtc; \