summaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2023-05-25 02:31:17 -0400
committerPetr Štetiar <ynezz@true.cz>2023-06-05 08:31:47 +0200
commitd87a8aa148ddf93b199a759deb088fff73787025 (patch)
tree5f96d125bf2f59682c1fd6a8e96d48b80d1d3ead /target/imagebuilder
parent1bad93c42669061b0248ca5cff1d83e399a2ef1a (diff)
downloadopenwrt-d87a8aa148ddf93b199a759deb088fff73787025.tar.gz
openwrt-d87a8aa148ddf93b199a759deb088fff73787025.tar.bz2
openwrt-d87a8aa148ddf93b199a759deb088fff73787025.zip
treewide: add ORIG_PATH variable
Add a variable that stores the original value of $PATH in the host system's shell, before Make alters it. This can be useful for when it is necessary to ignore symlinks and programs made by the build system. Define this new variable before all instances of 'export PATH:=' or similar. Signed-off-by: Michael Pratt <mcpratt@pm.me>
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/files/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index 5aeedb74da..5020373792 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -13,6 +13,7 @@ export TOPDIR LC_ALL LANG
export OPENWRT_VERBOSE=s
all: help
+export ORIG_PATH:=$(if $(ORIG_PATH),$(ORIG_PATH),$(PATH))
export PATH:=$(TOPDIR)/staging_dir/host/bin:$(PATH)
ifneq ($(OPENWRT_BUILD),1)