summaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2024-11-17 19:19:36 +0000
committerPetr Štetiar <ynezz@true.cz>2024-11-17 19:54:54 +0000
commitefc0c4666b5aa0cf0067d794964f12d9a45190c6 (patch)
tree28342fade817f60a8e9387602e83086033c6be69 /target/imagebuilder
parent90f0be8521a8608b0932c1ccb747c0ef1a085910 (diff)
downloadopenwrt-efc0c4666b5aa0cf0067d794964f12d9a45190c6.tar.gz
openwrt-efc0c4666b5aa0cf0067d794964f12d9a45190c6.tar.bz2
openwrt-efc0c4666b5aa0cf0067d794964f12d9a45190c6.zip
imagebuilder: fix DEFAULT_PACKAGES handling
DEFAULT_PACKAGES handling was moved in commit 40be892a020e ("imagebuilder: move handling of DEFAULT_PACKAGES into shareable place") to `include/default-packages.mk`, but they weren't removed from ImageBuilder's Makefile, so lets remove it now. Once removed, I've noticed, that it stopped working as there is target.mk included later in that file, overriding the DEFAULT_PACKAGES again, so moved it after this target.mk include. Fixes: 40be892a020e ("imagebuilder: move handling of DEFAULT_PACKAGES into shareable place") Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/files/Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index c4e2c390fe..d1502d40c1 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -26,7 +26,6 @@ include $(INCLUDE_DIR)/debug.mk
include $(INCLUDE_DIR)/depends.mk
include $(INCLUDE_DIR)/rootfs.mk
-include $(INCLUDE_DIR)/default-packages.mk
include $(INCLUDE_DIR)/version.mk
export REVISION
export SOURCE_DATE_EPOCH
@@ -105,6 +104,7 @@ APK:=$(call apk,$(TARGET_DIR)) \
include $(INCLUDE_DIR)/target.mk
+include $(INCLUDE_DIR)/default-packages.mk
-include .profiles.mk
USER_PROFILE ?= $(firstword $(PROFILE_NAMES))
@@ -139,11 +139,6 @@ _call_info: FORCE
echo 'Available Profiles:'
echo; $(PROFILE_LIST)
-ifneq ($(CONFIG_USE_APK),)
- DEFAULT_PACKAGES += apk-mbedtls
-else
- DEFAULT_PACKAGES += opkg
-endif
BUILD_PACKAGES:=$(sort $(DEFAULT_PACKAGES) $($(USER_PROFILE)_PACKAGES) kernel)
# "-pkgname" in the package list means remove "pkgname" from the package list
BUILD_PACKAGES:=$(filter-out $(filter -%,$(BUILD_PACKAGES)) $(patsubst -%,%,$(filter -%,$(BUILD_PACKAGES))),$(BUILD_PACKAGES))