summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/lzma-loader/src
diff options
context:
space:
mode:
authorJonas Gorski <jonas.gorski@gmail.com>2017-12-13 11:12:11 +0100
committerJonas Gorski <jonas.gorski@gmail.com>2017-12-13 11:34:51 +0100
commiteeeee885fb497bb07041575b78fca4063145edb9 (patch)
tree6b671578adf6181d02db4e57097842849864d372 /target/linux/ar71xx/image/lzma-loader/src
parent30e18c8d64cfa58aa42eececcda728824a4bebaf (diff)
downloadopenwrt-eeeee885fb497bb07041575b78fca4063145edb9.tar.gz
openwrt-eeeee885fb497bb07041575b78fca4063145edb9.tar.bz2
openwrt-eeeee885fb497bb07041575b78fca4063145edb9.zip
ar71xx: fix lzma-loader build with glibc
For an unknown reason gcc tries to link in crti.o when building with a glibc toolchain (this does not happen with other targets). Prevent this by telling gcc explicitly to not do that. Fixes the following build error: /home/jonas/git/lede/staging_dir/toolchain-mips_24kc_gcc-5.5.0_glibc/lib/gcc/mips-openwrt-linux-gnu/5.5.0/../../../../mips-openwrt-linux-gnu/lib/crti.o: In function `_init': (.init+0x18): relocation truncated to fit: R_MIPS_GOT16 against `__gmon_start__' /home/jonas/git/lede/staging_dir/toolchain-mips_24kc_gcc-5.5.0_glibc/lib/gcc/mips-openwrt-linux-gnu/5.5.0/../../../../mips-openwrt-linux-gnu/lib/crti.o: In function `_init': (.init+0x28): relocation truncated to fit: R_MIPS_CALL16 against `__gmon_start__' collect2: error: ld returned 1 exit status Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/image/lzma-loader/src')
-rw-r--r--target/linux/ar71xx/image/lzma-loader/src/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/lzma-loader/src/Makefile b/target/linux/ar71xx/image/lzma-loader/src/Makefile
index 682b31fe8c..c54f64a550 100644
--- a/target/linux/ar71xx/image/lzma-loader/src/Makefile
+++ b/target/linux/ar71xx/image/lzma-loader/src/Makefile
@@ -33,7 +33,7 @@ BIN_FLAGS := -O binary -R .reginfo -R .note -R .comment -R .mdebug \
CFLAGS = -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
-fno-strict-aliasing -fno-common -fomit-frame-pointer -G 0 \
-mno-abicalls -fno-pic -ffunction-sections -pipe -mlong-calls \
- -fno-common -ffreestanding -fhonour-copts \
+ -fno-common -ffreestanding -fhonour-copts -nostartfiles \
-mabi=32 -march=mips32r2 \
-Wa,-32 -Wa,-march=mips32r2 -Wa,-mips32r2 -Wa,--trap
CFLAGS += -D_LZMA_PROB32